Results 1 to 9 of 9
  1. #1

    would this cause rpm loss

    So, I had my 06 rxp out on some glass yesterday morning and the rpms were maxing out at 7700, it would not go past that and for the most part stayed around 7640(i dont have a gps but the speedo read 69). I took a look at the impeller and the fins circled in red in the picture were bent. Would this cause my rpm loss and can i replace the part or maybe try to strighten them out.

  2. #2
    forgot the picture and the impeller and wear ring had to be replaced about a year ago because one of my friends sucked up some rocks in shallow water
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	impeller.JPG 
Views:	101 
Size:	57.1 KB 
ID:	77106  

  3. #3
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Catawba Island, Ohio
    Try to load the picture again. Use the Manage Attachments button below to load a picture from your PC. Then use Preview Post to see if the picture was loaded before you use the Submit Reply button... Ron

  4. #4

  5. #5

    Join Date
    Nov 2006
    Might just be the angle of the picture , but they look fine to me. What were your RPM's before ? Maybe need a wear ring or maybe just heat fade ?

  6. #6
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Visalia, Ca
    The fins look fine. What was the air and water temp? What is the distance between your impeller and wear ring? how does the wear ring look? What is your oil level when hot (ski must be level)?

  7. #7
    Dont judge me...
    Join Date
    Jul 2006
    the prop could be bent... also look here for more....

  8. #8
    Big K's son KeithKman's Avatar
    Join Date
    Dec 2006
    Southern California
    Why did you use my pic? lol. The fins in the pic are fine because that is a pic of MY ski.

    They fins are not straight, they are angled slightly. That is normal.

    Maybe take a pic of YOUR ski so we know what you are talking about?

  9. #9
    yeah, lol my fins are bent I borrowed the picture because i didnt have my camera on hand when i was putting the ski away. The fins are bent over to the left. the picture was just for reference because i dont know what they are called

    mine fins look bent and some look chewed up a bit. the temp was about 80-90 id say, it was in the morning in texas. water temp was 77-80
    Last edited by Nadroj; 06-12-2008 at 10:36 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What causes a loss in rpms
    By swafia in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 12-20-2011, 09:23 PM
  2. sl900 bottom grate missing, will this cause low rpm problems?
    By redfro in forum Polaris Open Discussion
    Replies: 1
    Last Post: 09-01-2010, 10:12 AM
  3. Would this cause cavatation? (pictures inside)
    By clpsuite in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-29-2007, 04:37 PM
  4. Jerry - Loss of rpm - loss of speed
    By RXPDAVID in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-13-2005, 03:47 PM
  5. Would this be an ok mod setup for a budget????
    By kenshin89 in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-25-2005, 07:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts