Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    Stop Obama Express
    Join Date
    Apr 2008
    Location
    Lexington, KY
    Posts
    256

    Installing impeller... at work and need ASAP help

    I am removing the impeller counter clockwise but the more it turns, the hard it gets. I have it soaking in PB blaster and it WILL come out soon but the question is....

    Do i locktite the new one on and/or what is the torque?

    Thanks guys


  2. #2
    JayZ's Avatar
    Join Date
    Feb 2006
    Location
    mississauga, ontario
    Posts
    407
    +1
    1
    use some heat on the impellor to melt the loctite that is on the threads. then work the impellor back and forth to remove it from the shaft. if you have some crap in the threads you will damage the shaft or impellor threads if you force it too much.

    i always use loctite on the impellor. not sure of the torque, but i just tighten it by feel. i would guess in the 75 ft.lb range. just make sure it is really snug.

  3. #3
    Stop Obama Express
    Join Date
    Apr 2008
    Location
    Lexington, KY
    Posts
    256
    Alright, i used a good amount of red loctite and tightened a good amount with my matco 1/2" breaker bar. It seems to be good now.

    It pissed me off to see that the impeller I am sending back for a core ended up being a Solas and damaged pretty good. Hope SBT doesnt have a problem with that.

    One pump down.... one more to go.

  4. #4
    LOL I never use any loctite, sometimes antisieze and NEVER red loctite! R u a glutton for punishment???

  5. #5
    JayZ's Avatar
    Join Date
    Feb 2006
    Location
    mississauga, ontario
    Posts
    407
    +1
    1
    i've never had any problems with putting loctite on my impellors...

  6. #6
    Faster Than a Snail on a Log mongorunner's Avatar
    Join Date
    Jun 2007
    Location
    North of Amarillo TX
    Posts
    741
    Quote Originally Posted by 240witSR View Post
    Alright, i used a good amount of red loctite and tightened a good amount with my matco 1/2" breaker bar. It seems to be good now.

    It pissed me off to see that the impeller I am sending back for a core ended up being a Solas and damaged pretty good. Hope SBT doesnt have a problem with that.

    One pump down.... one more to go.

    red loctite is pretty much a PITA on anything

  7. #7
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    Grease on the impeller threads for me said the saltwater guy.

  8. #8
    Stop Obama Express
    Join Date
    Apr 2008
    Location
    Lexington, KY
    Posts
    256
    Quote Originally Posted by water worx View Post
    Grease on the impeller threads for me said the saltwater guy.
    I used some good ol' Volvo high pressure grease that we use on axle splines. WHOO!

  9. #9
    Did you use red loctite or grease??? I am soooo confused

  10. #10
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Quote Originally Posted by JJJ View Post
    Did you use red loctite or grease??? I am soooo confused
    Yeah...me too!

    I never use any loctite on the prop. Anti-seize seems to stay put better than grease.

    You guys have to think about it from BRP's point of view. They don't want the prop coming loose within their warranty period by the dummy that couldn't tighten it properly at the factory. So, loctite is good insurance. Otherwise, if you ever have to struggle getting one off, you'll never use it again.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 18
    Last Post: 04-29-2010, 07:22 PM
  2. Wanted and needed asap gas cap
    By Slick PWC in forum Polaris Classifieds
    Replies: 9
    Last Post: 09-10-2009, 12:45 AM
  3. Replies: 6
    Last Post: 07-10-2009, 09:34 AM
  4. Hello, I'm new here and need some help....
    By RXP Keith in forum 4-Tec Performance
    Replies: 17
    Last Post: 06-19-2007, 06:47 PM
  5. Got a Garmin 76csx and need map help.
    By blownhotrodder in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 06-15-2007, 01:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •