Results 1 to 5 of 5
  1. #1

    650sx bog? help please

    i have a 91 650sx that bogs alot and the plugs are still good and by the end of the day it keeps getting worse like i cant even get onto a plane holding the throttle full open but after like 5 mins a putting around going 10mph it will go and going high speed it seems ok but not too good like not full power any ideas? i think it has something to do with the high and low adjustments on the mikuni 44mm carb not sure tho. last weekend i was messin with the low speed but didnt seem to make a difference


  2. #2

    Join Date
    Jun 2008
    Location
    Alabama
    Posts
    16

    Mine does the dame thing

    I have a 89 650sx with a 46mm Mikuni and it does the exact same thing. Not trying to steal your post, I just hope somebody knows what the problem is.

  3. #3
    Test Pilot and Racer for Hire phoenixcustoms's Avatar
    Join Date
    May 2007
    Location
    Alabama
    Posts
    1,022

    Check this out

    Hey Peter check this out.......I could have tried to tell you but I figured I would let this website do the talking.......I know that some of the stuff on there is not in your case but other parts of it are...

    http://www.groupk.com/sep.htm

    Trust Me Read the whole thing....I know its long but this type of thing we were talking about the other day happens to a lot of 2 strokes....It happened to all of mine....
    Last edited by phoenixcustoms; 07-01-2008 at 03:36 PM.

  4. #4
    Test Pilot and Racer for Hire phoenixcustoms's Avatar
    Join Date
    May 2007
    Location
    Alabama
    Posts
    1,022
    Now I am not saying you need this part but I do remember running an air seperator on all mine....But it came with my carb, and jet kit.....

  5. #5
    Can you post pics of the plugs? While out running it, once it starts acting up hold it wide open and kill the engine. Get it to shore and pull the plugs and take a few pics. It will help a lot with determining the cause or a good starting point. But it does sound like the carb needs to be pulled and allowed to soak for 20 minutes or so in some real carb cleaner such as Hydroseal. Adjusting the low speed won't help because it's a high speed issue. The low will only change how it idles, rough and wanting to stall...or lean and hanging on high idle when you touch the throttle.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 1200xl ltd dies at idle and bogs sometimes, please help
    By Rookiepwc in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 09-12-2013, 05:16 PM
  2. 03 gti bog issue Please Help
    By g88ghost in forum 2-Stroke Performance
    Replies: 13
    Last Post: 05-29-2013, 11:32 AM
  3. 1997 GTX bogging/stalling help please.
    By cfnnslsq in forum 2-Stroke Performance
    Replies: 3
    Last Post: 05-24-2011, 11:13 PM
  4. dual mukini on 88 650sx help please!! need experts
    By mattmill91 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-06-2010, 03:55 PM
  5. 1200R Engine/Bog Issue, PLEASE HELP
    By GP1300Racer in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-14-2009, 08:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •