Results 1 to 1 of 1
  1. #1

    RPM Gauge Issues?


    I bought a RPM gauge for my 93 Sl650, the guy said it should work fine, and i didnt see why not. I got it today, and its reading some crazy rpm's. It reads about 4-5k at idle, which sounds like 2k to me, and it reads 10k at WOT.
    This is it...

    Does my ski spark 2x per revolution or something? The thing is stupidly slow as well. It says 10k, then you let off the gas, and it says 11k, 10k, 10k, 9k, 9k, 8k, 7k,.... and about 5 seconds later the thing finally says idle speed, even though it actually went back down to idle in a second....
    Last edited by ZOMGVTEK; 06-11-2008 at 07:59 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Tiny Tack RPM gauge
    By 1400gprmike in forum Yamaha Classifieds
    Replies: 3
    Last Post: 04-28-2009, 02:58 PM
  2. Help with VX110 Gauge Issue
    By JeffSki in forum Yamaha How To & FAQs
    Replies: 0
    Last Post: 04-02-2008, 02:41 PM
  3. 06 RXP Stage 1'd RPM & Power issues
    By mab546 in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-30-2007, 07:50 PM
  4. speedster S200 owners - rpm sync issue
    By cyoungesq in forum Sea Doo Sport Boats
    Replies: 7
    Last Post: 06-03-2007, 10:22 PM
  5. stock 06 sea doo rxp RPM gauge shows 8360
    By XRIDER in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 01-27-2007, 05:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts