Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    Alex The Godfather's Avatar
    Join Date
    Jan 2008
    Location
    NC
    Posts
    945

    Cavitation after flipping

    My friend flipped his seadoo and we flipped it back over and then it ran fine for a minute or so but then started to cavitate BADLY. any ideas or suggestions

    is it a impeller thing, pump thing or what?


  2. #2
    Has he even looked at it yet?

  3. #3
    Alex The Godfather's Avatar
    Join Date
    Jan 2008
    Location
    NC
    Posts
    945
    no he isnt really into the whole mechanical thing and im not much help as i only know the basics and i didnt havea chance to look at anything so what i could help with i couldnt even help

    i think he is just going to call a dealership because tomorrow im working again so it will be later b4 i can see it and he doesnt want to wait.

  4. #4
    Bow chicka wow wow
    Join Date
    Sep 2006
    Location
    Charlotte,NC
    Posts
    490
    +1
    5
    Every time I have had a cavitation problem is has been pump/wear ring/impeller related. Also had the problem when I broke my pump shoe. Plastic POS!!!!

  5. #5
    Alex The Godfather's Avatar
    Join Date
    Jan 2008
    Location
    NC
    Posts
    945
    thats what i was thinking and he just had the wear ring replaced after he blew one by driving it hard

    i told him to replace the ceramic p.o.s.'s with stainless ones but he didn't listen and he blew them, then i told them since they were replacing them to just go ahead and change them but no so who knows what happened know.

    if it is a wear ring thing ill be saying "somehow i told ya so doesn't quite do it"

  6. #6
    Bow chicka wow wow
    Join Date
    Sep 2006
    Location
    Charlotte,NC
    Posts
    490
    +1
    5
    Nice X godfather. Where in NC are U?

  7. #7
    Alex The Godfather's Avatar
    Join Date
    Jan 2008
    Location
    NC
    Posts
    945
    thanx, i'm in Hickory

    about an hour away from you.

  8. #8
    Alex The Godfather's Avatar
    Join Date
    Jan 2008
    Location
    NC
    Posts
    945
    hey pirate,

    is your ski the black and red version?

  9. #9
    Bow chicka wow wow
    Join Date
    Sep 2006
    Location
    Charlotte,NC
    Posts
    490
    +1
    5
    That's it. Mostly run on Lake Wylie.

  10. #10
    Alex The Godfather's Avatar
    Join Date
    Jan 2008
    Location
    NC
    Posts
    945
    nice, that is probly one of my favorite colored seadoos ever.

    that and mine and the 07 RXP

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cavitation after sealing the pump shoe...
    By Goliath in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 07-23-2011, 05:02 PM
  2. RXP-X cavitation after SC mod
    By ZeXteR in forum 4-Tec Performance
    Replies: 7
    Last Post: 10-18-2010, 10:04 PM
  3. Real bad cavitation after adding 1 Deg wedge and Riva Ridw plate
    By pierstar in forum Kawasaki PWC Performance (4-stroke)
    Replies: 7
    Last Post: 06-02-2010, 05:57 PM
  4. bad cavitation after intake grate replacement
    By KevinS in forum 2-Stroke Performance
    Replies: 7
    Last Post: 09-17-2009, 11:48 AM
  5. High Idle After Flipping Ski and Taking on Some Salt Water
    By ercBOOSTED in forum Kawasaki PWC Performance (4-stroke)
    Replies: 82
    Last Post: 07-12-2009, 09:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •