Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1

    1998 Seadoo Gsx Limited Help!!!!!!!

    Ok here is the issue, I have a 1998 gsx limited and the first time I had it out it ran fine. The second time I had it out it ran fine. The third time it was out it began to bog for no reason. When it was bogging at times it would run normal, especially when the impellar was out of the water, then it would bog when the back end was in the water and at random times just bog and then speed up. We changed the plugs, bypassed the selector switch, cleaned the carbs and the fuel filters in them. Changed the old grey fuel lines out. But the symptoms are the ski bogs until it gets out of water then it will run crisp then bog down again. If you have any ideas, please let me know, its driving me crazy..Maybe its something simple we are looking.. ..When on the trailor the ski runs and sounds crisp. Oh and also we rebuilt the pump as well. I appreciatre any suggestions

    Mike


  2. #2
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Rectifier is a possibility. I know 98's had the same ignition as older stuff, but I don't know where the rectifier is.

  3. #3
    race24x's Avatar
    Join Date
    May 2007
    Location
    Fayette, Maine
    Posts
    1,005
    Join the club Mike I have same year same problems

  4. #4
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    The 98's had gremlins in their wiring harnesses...

  5. #5
    steach's Avatar
    Join Date
    Dec 2005
    Location
    Rock Tavern, NY
    Posts
    3,174
    +1
    174
    Quote Originally Posted by 96XPSS View Post
    Rectifier is a possibility. I know 98's had the same ignition as older stuff, but I don't know where the rectifier is.
    RQ, I know this ski and have been on the phone and in this ski. I suggested the Rectifer last night but I find out it's in the MPEH. I would think you could test at the battery???

  6. #6
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    I think so Steach. If the voltage is over 13.9 volts the rectifier is bad. TLR is a 98 model specialist...I wish he would see this thread and post.

  7. #7
    steach's Avatar
    Join Date
    Dec 2005
    Location
    Rock Tavern, NY
    Posts
    3,174
    +1
    174
    Quote Originally Posted by 96XPSS View Post
    I think so Steach. If the voltage is over 13.9 volts the rectifier is bad. TLR is a 98 model specialist...I wish he would see this thread and post.
    Thanx, I'll PM him.

    It realy pisses me off that you need a new computer to replace a part the SD knows goes bad! -the rectifier is the ONLY part that SD alludes to going bad in their manual (no mention of Tempo lines or ceramic SC clutches).

  8. #8
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    I have a good used MPEM for a 98 GSXL..LMK

    Also I have a thought on how to fix this but never tried it yet....

    Take the 3 yellow wires & run them to a 800 Seadoo reg/rect & send the red wire back to the battery/starter solenoid. Should work ???
    Last edited by water worx; 06-12-2008 at 10:24 PM.

  9. #9
    steach's Avatar
    Join Date
    Dec 2005
    Location
    Rock Tavern, NY
    Posts
    3,174
    +1
    174
    Typical bog of early rec trouble

    Checklist:
    Carbs clean / lines new.
    Reserve direct to water seperator to carbs.
    Same problem with or w/out seat on.
    Jet pump serviced (twice cause of my mistake)
    -no wear or alignment issues

    To do:
    Test voltage.
    Swap rave covers to verify operation.

  10. #10
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Quote Originally Posted by water worx View Post
    I have a good used MPEM for a 98 GSXL..LMK

    Also I have a thought on how to fix this but never tried it yet....

    Take the 3 yellow wires & run them to a 800 Seadoo reg/rect & send the red wire back to the battery/starter solenoid. Should work ???
    Worx, I didn't know how it's connected, but now that you've described how it's wired, I see no resaon why it wouldn't. The red can connect anywhere to 12v hot.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1998 Seadoo GTX limited exhaust pipe HELP
    By chazdo2 in forum 2-Stroke Performance
    Replies: 5
    Last Post: 08-03-2016, 11:34 PM
  2. 1998 seadoo GSX limited
    By Jay146992 in forum 2-Stroke Performance
    Replies: 7
    Last Post: 07-09-2012, 09:15 PM
  3. Parting out: 1998 Seadoo GSX Limited
    By nightrider05 in forum Sea Doo 2 Stroke Skis
    Replies: 14
    Last Post: 07-06-2010, 03:28 PM
  4. FS 1998 SeaDoo GSX limited parting out
    By TDSTYG in forum Sea Doo 2 Stroke Skis
    Replies: 3
    Last Post: 05-27-2010, 09:36 AM
  5. 1998 seadoo gsx limited bog problem
    By dashig in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-29-2009, 03:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •