Results 1 to 7 of 7
  1. #1

    Join Date
    Jun 2008
    Location
    Ontario, Canada
    Posts
    7

    06 RXP Low RPM's, Supercharger, Low voltage...PULLED THE MOTOR

    Ok, so I got the infamous 62-6500 RPM's last weekend on my 06' RXP. Im pissed because I was planning on changing out the ceramics for metal this weekend! My buddy had a spare set of metal washers.

    I'm almost certain that it's the superchager, so I went out and bought a rebuild kit (08' which comes with titanium coated washers). By the way, no more warranty and the qoute from the dealer was 650 if just the SC and about 2 grand if they had to do the oil pumps...

    So i have the kit, the service manual, a case of beer, the number for the pizza joint in town, and two buddies who rebuild engines n **** all the time. I think we can do it.

    But I just started thinking... When the 6500 rmo happend, I also noticed a 12V Low code on the ski. I didnt really think too much about it, but I talked to a few people and they mentioned that if the battery was ****, it could cause a loss in RPM. Normally I woiuldnt think that would cause something like this, but last year I had a battery go **** on me in the middle of the river, and it actually started of with loss of power and sporatic reving. Right now the revs are not sporatic, but constant.

    What do you guys think, a possibility that the battery has something to do with it? It starts up no prob, but who knows, maybe it's crapola and doesnt have enough juice...

    Thanks in advance fellas

    ps. feel free to throw me some tips on the rebuild

    pss. I hate having a broken sea donkey!
    Last edited by dcvet; 06-15-2008 at 06:53 PM. Reason: update!


  2. #2

    Join Date
    Jan 2007
    Location
    Lakeland, FL
    Posts
    1,414
    No need to speculate what it is, just take the intake hose off the SC and see if the fan inside spins freely. If it does, you had a ceramic washer blow, if not, that's when you wonder if it's electrical.

  3. #3

    Join Date
    Jun 2008
    Location
    Ontario, Canada
    Posts
    7
    yup, just did it and it spin freely. Now Im crossing my fingers and hoping that the washers are still there!

  4. #4

    Join Date
    Jun 2008
    Location
    Ontario, Canada
    Posts
    7
    ahh, just noticed you're in lakeland. I used to come down to that area about 4 times a year to skydive in Zephyrhills(Im in canada)...

  5. #5

    Join Date
    Mar 2008
    Location
    Harrisonville Missouri
    Posts
    239
    So are they gone? How bad is it?

  6. #6

    Join Date
    Jun 2008
    Location
    Ontario, Canada
    Posts
    7

    pulled the motor, found some ceramic surprises

    oh yeah, they're gone.

    I pulled the motor yesterday and checked the oil pumps. Front pump had a ton of ceramic in it, rear pump about 50 percent of what the front had. The inner and outter rotors, and pumps covers were scored to ****. I went to the dealer yesterday and grabbed some new parts for the pumps yesterday and I'm putting it back together tonite.

    I should also mention that the oil filter was full of ceramic fragments.

    What I plan to do is throw it back together, new oil filter and oil, run for about an hour, then change out the oil and filter again to see if there's any more crap in there and just to be sure I get everything out.

    I took a ton of pictures that show the supercharger shaft with no washers, ceramic in the filter, ceramic in the pumps and a whole bunch of others. I'll post them so everyone can see what to expect.

    Now I have another questions for those that have experiences this? Have you had any problems after rebuilding the SC and oil pumps, and getting post of the crap out of the motor? I cant help but think is I have that scoring in the oil pumps, than maybe there's a chance that I could have got more internal damage i.e. pistons, etc

  7. #7
    Dr Len's Avatar
    Join Date
    Jan 2006
    Location
    New Jersey Attitude Capital of the World
    Posts
    1,170
    Talk to Shibby He's seen it all. All I can say is that Rob the mechanic at Formula One does'em right. And has had no problems.I know he replaces the front and rear covers and a bunch of other parts too.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 06 RXP low hours MD
    By bogey0911 in forum Sea Doo 4Tec Skis
    Replies: 16
    Last Post: 09-10-2009, 03:50 PM
  2. stock 04 RXP low RPM's help
    By sylvan in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-18-2009, 03:29 PM
  3. 06 RXP Low Hours Great Condition
    By CarFanatic in forum Sea Doo 4Tec Skis
    Replies: 15
    Last Post: 08-04-2009, 06:08 PM
  4. 06 rxp low rpm
    By rxpenpastu in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-21-2006, 02:25 PM
  5. New 04 RXP Low RPM & Speed
    By RXP04 in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-02-2005, 09:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •