Results 1 to 8 of 8
  1. #1

    Quick RPM Question

    Hi folks, could you settle a little bet for me.. my dealer says that my 2005 RXT is running just fine. I got the boat back from a service and found that the rpms were down about apx. 7700 with WOT on calm water. The wear ring and impeller are fine so I had him drain some oil as it was obviously overfilled and the rpms came back to 7900-7950 under the same conditions. My question is 1. is apx. 7900-7950 normal?
    2. the dipstick shows about 1/8 inch above
    the full bend when hot; is this safe or I have
    cart the thing back for another draining.

    I appreciate the advice before I hash it out with the dealer Wiki711


  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    oil level is still too high. It should be in the middle of the 2 bends when hot. Take some more out, and the rpms should be up more. 8100 is ideal.

  3. #3

    Join Date
    Jun 2006
    Location
    toronto
    Posts
    965

    Oil

    Biggest service problem on the planet if overfilling

  4. #4
    so how can i remove some tonight? problem is i dont have a suction pump and returning to the dealer is a half day event. is there a way to jury rig a removal device with common household stuff until i can order the pump? Also, and this is the big question, am i risking damage to the engine by running it as is?
    Thanks folks i appreciate the help

  5. #5
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Engine will be ok to run as is. Napa sells a drill pump, that you can use to suck oil out with. U will just need some plastic tubing that will fit down the dipstick hole.Or maybe rig up an old elec fuel pump??

  6. #6
    BertInTexas's Avatar
    Join Date
    May 2005
    Location
    Central Texas
    Posts
    377
    In the middle of the two bends huh? I checked mine yesterday and it was just below the top bend.I got out my new siphon pump and managed to remove about 1/2 a quart,but I was beginning to make a mess,(in the water at the time) and that oil was HOT!! I gave it up for then and just rode the rest of the day.After removing the 1/2 quart I was still at 7500 at wot.Do I need to remove more? Jerry? Guys? Anybody? I sure miss my 8100
    Last edited by BertInTexas; 07-03-2006 at 01:19 PM.

  7. #7
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Bert, Remove untill it's in the exact middle of the stick when hot. How does your wear ring look? Is your prop nose cone on and tight? these can all cause loss of rpms. Also external IC's can leak boost thru plumbing, and the block off. Prop may need to be pitched,and/or SC clutch slippage tested also.

  8. #8
    Been there and back! BDNJ's Avatar
    Join Date
    Jul 2005
    Location
    Silver Bay, Toms River, N.J.
    Posts
    1,536
    Guys: One more thing to check. I just checked out a buddy's 80 hr Stg I riva rxp. He had salt deposits on the #2 and #3 plugs. Rpms were down to 7750. I heard from a tech that stock i/c's are leaking. Wait til I post the pics. His was so corroded inside it was unbelieveable. It was completely white (salt) rather than stainless colored. I put my old one in there and he will be going out this wknd.
    Last edited by BDNJ; 07-06-2006 at 11:00 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RPM Question
    By Snoman in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 05-21-2006, 07:33 PM
  2. RXP First Ride...RPM Question
    By Teddy57 in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-16-2006, 06:13 PM
  3. RXP First Ride....RPM Question
    By Teddy57 in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 05-15-2006, 03:59 PM
  4. rpm question
    By brad2510 in forum 4-Tec Performance
    Replies: 7
    Last Post: 04-20-2006, 12:45 PM
  5. RPM QUESTION
    By Carlos Miami RXP in forum 4-Tec Performance
    Replies: 46
    Last Post: 04-12-2006, 01:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •