Results 1 to 3 of 3
  1. #1

    Arrow Help me fix the MFD

    What can I do???
    It died while I was jumping my seadoo with the battery still connected to the polaris....

    Replaced the fuse in the black box and still no dice.

    Just another case of me being impatient.


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    WELCOME to the Green Hulk Forums!!
    Try disconnecting the MFD for a couple of hours and see what happens.
    Have you verified that you have power and ground at the MFD?

  3. #3

    Join Date
    Aug 2006
    Location
    Iowa
    Posts
    1,028
    +1
    2
    Their is also a 1/4amp fuse for the MFD that may have blown.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. help me understand the cooling system and this diagram on our 4 tecs..
    By wisconsin_quat in forum 4-Tec Performance
    Replies: 4
    Last Post: 04-11-2009, 04:48 PM
  2. Help me determine the value of a used pump PICS!
    By gbest in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 07-31-2008, 06:39 PM
  3. Help me remove the front vent tubes PLEASE (RXP-X)
    By Mikey G. in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-02-2008, 10:42 PM
  4. Help me get the gear there...
    By Whaler in forum Open Discussion
    Replies: 7
    Last Post: 02-27-2008, 11:46 PM
  5. Sucked up rocks!!!!! Help me with the damage!
    By TorquePhoto in forum 4-Tec Performance
    Replies: 16
    Last Post: 08-01-2006, 03:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •