Results 1 to 4 of 4
  1. #1

    Join Date
    Jul 2007
    Location
    Cleveland, Ohio
    Posts
    43

    RXP Problem...Few Questions

    I have two 07 RXPs both of them with about 52 hrs on them. They are bone stock except for opas blockoffs. Lately, it feels like I have lost throttle response and low end accelleration. It seems to be fine when im in high rpms. When i stab the throttle from a standstill it seems to be missing a little bit also. I have checked the battery and cleaned the connections so i know its not that. I also checked the plugs and the insulator is completely white. To me, it seems to be running quite lean. Could my supercharger be going bad? Im pretty new to these machines but i know my way around motors.


  2. #2
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Quote Originally Posted by RXPSC215 View Post
    I have two 07 RXPs both of them with about 52 hrs on them. They are bone stock except for opas blockoffs. Lately, it feels like I have lost throttle response and low end accelleration. It seems to be fine when im in high rpms. When i stab the throttle from a standstill it seems to be missing a little bit also. I have checked the battery and cleaned the connections so i know its not that. I also checked the plugs and the insulator is completely white. To me, it seems to be running quite lean. Could my supercharger be going bad? Im pretty new to these machines but i know my way around motors.
    It sounds like your wear ring might be worn. It's about $45 to replace. But, new plugs would cost $15, so you might try that first. Did you buy your skis from Dave C. at Powersports? I'm over near Port Clinton... Ron

  3. #3

    Join Date
    Jul 2007
    Location
    Cleveland, Ohio
    Posts
    43
    Thanks for the help, I think im gonna try a new wear ring. I bought the skis from Chris V. They are great people over there. I am actually down in Brecksville/Broadview Hts. area.

  4. #4
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    My ski is just in front of Ryan Tuckers 55' Sea Ray Flybridge. He was limping pretty bad a week ago, but he looked much better tonight. Maybe he'll start with the Browns this fall... Ron

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New RXP-X - Few questions - Is this normal?
    By boostaholic in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-29-2008, 11:01 AM
  2. Looking at a used S3 RXP... few questions.
    By BigKID in forum 4-Tec Performance
    Replies: 13
    Last Post: 02-22-2007, 11:01 PM
  3. Soon to buy an rxp a few questions though
    By red rider in forum Sea Doo Open Discussion
    Replies: 23
    Last Post: 10-12-2006, 10:01 PM
  4. about to buy 06 rxp, have few questions before I buy
    By CarFanatic in forum Sea Doo Open Discussion
    Replies: 18
    Last Post: 05-30-2006, 07:35 PM
  5. A few questions about my RXP
    By Teddy57 in forum 4-Tec Performance
    Replies: 2
    Last Post: 01-28-2006, 02:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •