Results 1 to 8 of 8
  1. #1
    Stock Soup mr.candid's Avatar
    Join Date
    Apr 2008
    Location
    Syracuse, NY
    Posts
    159

    Unhappy Pro 1200 noise NOT a good day

    I cant get over this thing, i buy this jetski goes good for a few hrs, have to dump money into it, ride it again for a few hrs, dump more money. Just problems after problems. Today went well untill i took the jetski out of the water, i rode for a few hrs with a friend around are local lake, tons of fun. When i take it out of the water i start it up for a second to clear the water out of it and i here a noise ive never heard before. When i got home i took out the plug and cranked it over, every half to full turn of the prop i hear a click, like the prop is hitting something. Then i look in the back end and i see this. I take it i will need a new strator or pump housing assembly. Let me know what you think.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	SNB12119.JPG 
Views:	87 
Size:	1.64 MB 
ID:	77812  


  2. #2
    PolarisNut's Avatar
    Join Date
    Dec 2006
    Location
    Lower Michigan
    Posts
    1,809
    Looks like you sucked up a rock and it got jammed between the impeller and the stator.

  3. #3
    Stock Soup mr.candid's Avatar
    Join Date
    Apr 2008
    Location
    Syracuse, NY
    Posts
    159
    Where can i get this part for realitively inexpensive ?

  4. #4

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    you can send it to impros and get it repaired or just try and find a good used one, even if you just get a good 5 vane for the time being . sure looks like you sucked something up

  5. #5
    Rasta Mon Condoms We Be Jammin!!!!! TxVirageTx's Avatar
    Join Date
    Aug 2006
    Posts
    5,775
    +1
    400

    stator

    man how do you guys do that????thats bad,start looking for another stator,contact seatsr4toilets he's got one off his 99slx
    Last edited by ph2ocraft; 06-15-2008 at 08:16 PM. Reason: added link

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Quote Originally Posted by mr.candid View Post
    ...I see this.
    I take it i will need a new stator or pump housing assembly.
    Let me know what you think.
    Is the impeller bent, and contacting the wear ring housing around the impeller?

    Or is it just the stator that is damaged?

    In the short term, you can just file the rough edges down so it doesn't touch the impeller, and smooth it all down as best you can.

    Some people ride with damaged stators for years. You will not get full performance, and the cavitation may slowly degrade the prop, but it should run sort-of-OK while you source a replacement.

  7. #7
    la90043's Avatar
    Join Date
    Oct 2006
    Location
    Los Angeles
    Posts
    1,201

    For the future

    In the future do not ride in very shallow water. do not start the pwc near the shore and also look out for floating debris (wood, logs) etc. Also when you let the best buddy use it too that can happen.

  8. #8
    Stock Soup mr.candid's Avatar
    Join Date
    Apr 2008
    Location
    Syracuse, NY
    Posts
    159
    Well i took apart it and just bent it back it to shape as best i can without comprimising even more the vein itself. The prop is fine, something defiantley got stuck in there though ; ) I should be fine for a while now

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MFD display on Pro 1200 does not work
    By FX-1 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 03-23-2015, 05:02 PM
  2. Not a good day on the water!
    By NetBret in forum Sea Doo Open Discussion
    Replies: 22
    Last Post: 05-21-2013, 10:02 PM
  3. not a good day for kawi ultra 150 owner
    By big john in forum Kawasaki PWC Performance (2-stroke)
    Replies: 7
    Last Post: 08-14-2012, 09:19 PM
  4. HELP - Not a good day on the lake...
    By lmiranda in forum 4-Tec Performance
    Replies: 21
    Last Post: 10-14-2008, 11:32 PM
  5. Rius takes pro 1200 world title in Havascrew...
    By 11 in forum Race Events and News
    Replies: 32
    Last Post: 10-20-2005, 11:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •