Results 1 to 5 of 5
  1. #1
    Old School Never Dies! codemanrose's Avatar
    Join Date
    Nov 2006
    Location
    Minnesota
    Posts
    819

    Raider Runs like a champ!!!...but...

    When they were fixing it they did something with the starter and it got hot. I dont know if it was the starter itself or a washer but they layed it on my hydro turf and fried 3 peices of it. This totaly sucks. But they are going to fix it all for free so I cant be too mad. I just dont get to ride it again. I did test it in moderate rough water (where you can here that it lifts off the water many times) before I had to give it back and was hitting 58's consistantly on the GPS. So I hope for again 61 - 62's and luckly break my top speed of 63.1 but that proly won't happen again. We will see though. My brother in law is sending me a new GPS from base...marines (its a Garmin) and I will be mounting that to the handlebars.
    Last edited by codemanrose; 06-15-2008 at 11:19 PM.


  2. #2
    cheatin' piston popper addicted's Avatar
    Join Date
    Jul 2006
    Location
    north jersey
    Posts
    6,188
    +1
    176
    cool. keep us posted

  3. #3
    shay_mcquaid's Avatar
    Join Date
    Jun 2008
    Location
    Lake City, Florida
    Posts
    19
    What was your speedo reading at your 58 mph on your GPS?

  4. #4
    When they were fixing it they did something with the starter and it got hot. I dont know if it was the starter itself or a washer but they layed it on my hydro turf and fried 3 peices of it.
    Hope the starter is ok long term ?

  5. #5
    Old School Never Dies! codemanrose's Avatar
    Join Date
    Nov 2006
    Location
    Minnesota
    Posts
    819
    Quote Originally Posted by shay_mcquaid View Post
    What was your speedo reading at your 58 mph on your GPS?
    Was saying 65 most of the time.

    I will try and make a video when I get the GPS. they go back to north carolina tomorrow (sister and brother in law) and when they get there he is sending it to me. I just need a good cool calm morning to do it. I hate using my dads all the time.
    Last edited by codemanrose; 06-19-2008 at 11:37 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Near 2000 hours and running like a Champ!
    By john belton in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 09-25-2011, 12:28 PM
  2. Sl650 no power, runs like weeds in propeller, but its clear
    By so/20 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 09-23-2011, 08:49 PM
  3. Rxdi idles like a champ. But that's it!
    By Joe Stang in forum 2-Stroke Performance
    Replies: 5
    Last Post: 07-24-2011, 02:35 AM
  4. First day and my new RXT runs like POOP!
    By 2006 RXT in forum 4-Tec Performance
    Replies: 7
    Last Post: 05-09-2007, 11:16 PM
  5. Rocks went in the intake grate now runs like crap! Help!
    By GeoRXT in forum 4-Tec Performance
    Replies: 33
    Last Post: 04-18-2006, 04:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •