Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    Pro 785 Wont accelerate first time out ??

    Bought a 97 785 Pro over the winter & took it out for the first time this weekend. Supposed to be fresh rebuild by a 785 guru, exhaust pressure tested for leaks & everything looks good/tight on engine & pipes. The ski starts fine and runs slugishly up to about 25-30 at say 1/4 throttle & just bogs at anything over 1/4 throttle. Exhaust valves are not opening at all & tach does not work on MFD (CDI Bad ?). Tried making 1/2 turn adjustments on carbs but did not change anything. I plan on testing valve actuator box & CDI. I realize there are a lot of places to look for problems after searching this site, but thought someone might have had this same problem that can help.

    Thanks, Ryan


  2. #2
    la90043's Avatar
    Join Date
    Oct 2006
    Location
    Los Angeles
    Posts
    1,201
    sounds like fuel issues.........................

  3. #3
    www.springbreak-florida.com rgard32's Avatar
    Join Date
    Dec 2006
    Location
    Saint Petersburg,Florida
    Posts
    665
    exhaust valves wont open until at least 4k rpm..... does sound like fuel issues...or possibly compression...

    might have to pull carbs and look at em...check internal filters..and check/change fuel lines etc..

    i would also check compression

    where are you from?

  4. #4
    la90043's Avatar
    Join Date
    Oct 2006
    Location
    Los Angeles
    Posts
    1,201
    LA..........Los Angeles


    Quote Originally Posted by rgard32 View Post
    exhaust valves wont open until at least 4k rpm..... does sound like fuel issues...or possibly compression...

    might have to pull carbs and look at em...check internal filters..and check/change fuel lines etc..

    i would also check compression

    where are you from?

  5. #5
    Tony's Avatar
    Join Date
    May 2007
    Location
    North Carolina
    Posts
    1,760
    +1
    38
    Quote Originally Posted by la90043 View Post
    LA..........Los Angeles
    Uh....I think he was asking Ryan.

  6. #6
    I am in Springfield, MO / Table Rock Lake. I will check compression & fuel delivery. It has aftermarket carbs, I beleive red top 44's ? Has stock fuel filter. Any place i should be looking for filters on carbs?

    Thanks.

  7. #7
    www.springbreak-florida.com rgard32's Avatar
    Join Date
    Dec 2006
    Location
    Saint Petersburg,Florida
    Posts
    665
    the filters on the carbs are inside the carbs..on the fuel pump side..(the side closest to the hull) there inside.... there very small..

  8. #8

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    check the fuel switch the like to plug up and cause problems

  9. #9
    Thanks guys. By fuel switch I assume you mean the on/off switch & does the fuel pickup in the tank have any type of filter or sock that could clog?

    Thanks, Ryan

  10. #10
    Feral's Avatar
    Join Date
    May 2008
    Location
    Georgetown, Ontario
    Posts
    216
    Quote Originally Posted by yeehaa View Post
    Thanks guys. By fuel switch I assume you mean the on/off switch & does the fuel pickup in the tank have any type of filter or sock that could clog?

    Thanks, Ryan

    up the knob at teh side with the On/Main --- OFF --- Res thats the selector/on off valve

    and from what I've seen no the Polaris line doesn't have any type of screen/sock on the sender unit

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 785 Pro - First Time Out This Year
    By Derwood98 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 06-02-2011, 08:50 AM
  2. Polaris Pro 785 first time out properly running.
    By matt160580 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 08-31-2010, 05:55 PM
  3. Polaris Pro 785 wont rev out!
    By 00pro785 in forum Polaris PWC Performance
    Replies: 5
    Last Post: 07-07-2008, 10:37 PM
  4. First time out
    By Pettee in forum Sea Doo Open Discussion
    Replies: 16
    Last Post: 01-28-2006, 08:12 PM
  5. First time out with stage 1 05 RXP Not happy.
    By Fastcat in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-10-2005, 09:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •