Results 1 to 2 of 2
  1. #1
    oilikeit2's Avatar
    Join Date
    Apr 2008
    Manahawkin, NJ

    2008 Wake OPAS Problem

    Is anyone else experiencing this problem????? It seems that with the new 2008 Wakes the inlet for the OPAS were moved to accomodate the ballast tank inlets. For some odd reason the screen on the OPAS inlet clogs frequently and will not allow water to go up through the tube to raise the OPAS on high speeds. This can create some difficulties with steering, balance and control. My marina notified SeaDoo who in turn opened a file to see if a correction is needed.

  2. #2
    Get the block up's and be done with it.....$2 and ten minutes.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. rxt 215 2008 top speed problem
    By thomas loh in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-24-2010, 09:03 AM
  2. 2008 hood shock problem continued
    By basketballtitan in forum 4-Tec Performance
    Replies: 17
    Last Post: 11-24-2009, 05:47 PM
  3. Seadoo 2008 RXP-X Problem!!!!!
    By powerhouse in forum 4-Tec Performance
    Replies: 16
    Last Post: 05-16-2009, 11:17 PM
  4. 2008 Fx Sho Problems?
    By DOERUN in forum Yamaha PWC Performance (4-stroke)
    Replies: 19
    Last Post: 08-10-2008, 11:16 PM
  5. What are some simple mods for the 2008 Wake?
    By skyline99k in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 06-03-2008, 06:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts