Results 1 to 7 of 7

Thread: Help Please...

  1. #1

    Help Please...

    Hello, I am very new to the whole PWC world and we have a Polaris 750sl that we keep getting water on top of the cylinders. It only seems to happen after it gets rolled. Once we take out the plugs and start it to blow all the water out it takes a little while but it again fires up. It seems to be taking in a lot of water though. Any suggestions on what the problem?


  2. #2

    Join Date
    Jun 2007
    Location
    Clay NY
    Posts
    99
    Quote Originally Posted by jameynshawn View Post
    Hello, I am very new to the whole PWC world and we have a Polaris 750sl that we keep getting water on top of the cylinders. It only seems to happen after it gets rolled. Once we take out the plugs and start it to blow all the water out it takes a little while but it again fires up. It seems to be taking in a lot of water though. Any suggestions on what the problem?
    does it take water in only when you roll it or when you are riding it?

  3. #3
    It only seems to take water in when I roll it.

  4. #4
    BBCaprice's Avatar
    Join Date
    Apr 2007
    Location
    Titusville FL
    Posts
    750
    Quote Originally Posted by jameynshawn View Post
    Hello, I am very new to the whole PWC world and we have a Polaris 750sl that we keep getting water on top of the cylinders. It only seems to happen after it gets rolled. Once we take out the plugs and start it to blow all the water out it takes a little while but it again fires up. It seems to be taking in a lot of water though. Any suggestions on what the problem?
    Dont roll it!! And if you do make sure when you right it in the direction according to the sticker on the back of the hull! There is water in the exhaust system and it needs to be rolled back towards the exhaust side. If you continue to ride it where the motor can ingest water you can seriously damage it.

  5. #5
    2000 pro 785 (son's) 1998 pro 785 (dads) old guy in mich's Avatar
    Join Date
    Aug 2007
    Location
    sw lower mich
    Posts
    350

    smart a**

    sorry but you left this one ripe for pickin........
    DONT ROLL IT!!!!!!!

    also ck siphon make sure its not leaving a lot of water in bilge
    ck seat seals ect
    seal electric box and plug wires too

  6. #6
    Bernie's Avatar
    Join Date
    Aug 2006
    Location
    Perth Australia
    Posts
    902
    +1
    1
    The smooth bit of the ski faces down for a reason .The common denominator here is the ski rolls and gets water in it .Grab a manual from the downloads and read it .The answers are in there .

    Bernie

  7. #7
    I am sure I did leave that one open....This last time was not intentional.....we were just trying to figure out why we kept getting water in the cylinders. Thanks for the answers though!!!! I do know that when we first bought it it had not been used in a while and we had to do the same thing then where we had to pull the plugs and get the water out. Like I said we are new to this side of sports.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need HELP Please!
    By GeoRXT in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-30-2006, 08:04 AM
  2. HEy Guys Need Help PLEASE!!!
    By SpeedStang95 in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-06-2006, 01:29 AM
  3. RXT 2005 Loose Hose - HELP PLEASE
    By BrAinZ in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-12-2006, 12:28 PM
  4. Can some one Post! A little Help Please!
    By Angelse68cal in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-04-2005, 07:57 PM
  5. RXP Handling !! Anyone help please
    By rxp_boy in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-17-2005, 02:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •