Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18

Thread: carb problem

  1. #1

    Join Date
    Nov 2006
    Location
    CT
    Posts
    210

    carb problem

    rebuilt my carbs on a 1200r engine, replaced all gaskets, filter and n/s with 1.5. (these are for my boat xr1800 but have done the ones on my skies in the past with no issues and they are the exact same carbs). i know you guys know your stuff so please advice.
    week ago installed the carbs with a pop off of 30 psi but was told by Beerdart that it really should be 43psi so i ordered the dull silver springs and started to replace but know all the carbs leak right after they pop....they do not leak before they pop only after they pop. i even installed the gold and they poped at 51 psi but started to leak right after they poped. i tried 5 of the six and the five i tried all did the same thing (leak after they pop).
    any ideas??
    i even reinstalled the cut springs that made them pop at 30 psi and they poped fine a week ago well now they pop at 30 and start to leak??
    The n/s are new (two weeks old). I did run the boat with the carbs poping at 30psi and it ran great, should have left it alone.

    please help i wanted to go out this weekend.
    thanks


  2. #2
    what are you wetting the needles with for testing? and yes I would have left it alone if it was running good

  3. #3

    Join Date
    Nov 2006
    Location
    CT
    Posts
    210
    WD40

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    What brand NS did you get?? WSM?? Mikuni??

  5. #5

    Join Date
    Nov 2006
    Location
    CT
    Posts
    210
    wsm

  6. #6
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Always use Mikuni genuine parts the WSM's are not worth the trouble.

  7. #7

    Join Date
    Nov 2006
    Location
    CT
    Posts
    210
    i am a lier, they are Mikuni, i purchased them through Dennis Kirk and they only sell the n/s 1.5 by mikuni.

  8. #8
    what are you using for an airsource? and if constant what psi?

  9. #9

    Join Date
    Nov 2006
    Location
    CT
    Posts
    210
    using a pop off gauge from Riva, and with the dull silver springs they pop at 41-42psi

  10. #10
    So they have a nice clean pop at 40 but if you go to do it again they leak or they leak right after the initial pop without pumping the gauge again?? I fill the whole area where the diaphragm sit with wd when I do it . it just sounds like your getting a dry needle that isn't re seating , is that a possibility?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99 xpl carb problems
    By cdoo951 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 10-06-2007, 08:18 PM
  2. GP carb problem-question
    By Mongoose in forum Yamaha Old School Skis
    Replies: 9
    Last Post: 06-27-2007, 11:54 AM
  3. 00 GP800 Carb Problem?
    By nubmturk in forum Yamaha Old School Skis
    Replies: 7
    Last Post: 06-08-2007, 04:47 PM
  4. 02 xlt 1200 carb problem
    By vomitspot in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 04-26-2007, 04:30 AM
  5. Carb Problems On My Xl 1300
    By Gj#6 in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 02-16-2007, 10:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •