Results 1 to 6 of 6
  1. #1

    Join Date
    Jan 2006
    Location
    Holter lake, montana
    Posts
    127

    Freezing problem???

    So i figured that the first week of june would be good enough to have my ski summerized and that there would be no more freezes up here in Montana. Well i was wrong because a few days later we got 7 inchs of snow!

    now its actually nice here and i want to go ride. but i am worried that the cold weather might have caused something to freeze. it only got to about 29 degrees but i want to be sure before i go ride. So my question is what can i or do i need to check before i start it up?


  2. #2
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Post the ski that you have so we have a better idea what may have frozen... Ron

  3. #3

    Join Date
    Jan 2006
    Location
    Holter lake, montana
    Posts
    127
    sorry its a 2005 rxp

  4. #4
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Well, you don't need to worry about the engine, since it has antifreeze in it. The only problem could be the intercooler which is inside the plastic intake manifold. I don't think that 29 degrees would hurt it, but when you take it out for the first time, just see how it runs at WOT. If it misses at WOT, the intercooler could be leaking. If it runs fine, don't worry about it. Have you changed out the ceramic supercharger clutches? If not, they could ruin your engine... Ron

  5. #5

    Join Date
    Jan 2006
    Location
    Holter lake, montana
    Posts
    127
    Thanks for your help. I do have the metal sc washers. So is there anyway to check the intercooler before i start it because i dont want to get water in the engine?

  6. #6
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    The only way you can test it is by doing a pressure test. Disconnect the both hoses, block one, and apply air pressure to the other & see if it leaks. Most would just run it for a short time to see if it misses at WOT... Ron

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Troubleshooting the Rotax Racing Stage I kit (was problems)
    By Jarrett in forum 4-Tec Performance
    Replies: 104
    Last Post: 10-22-2005, 08:12 PM
  2. riva stage 1 kit problems
    By macattack in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-28-2005, 05:08 PM
  3. Found my Problem with My RXP after Service.
    By Water4fire in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-20-2005, 03:12 PM
  4. Mysterious problem on my RXP
    By Jeff C in forum 4-Tec Performance
    Replies: 8
    Last Post: 06-13-2005, 10:08 AM
  5. 04 RXP Starting problem/question...
    By BLOWNRXP in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 06-01-2005, 10:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •