Results 1 to 4 of 4
  1. #1

    Exclamation 95 polaris SL650 runs 10 seconds then dies

    There was water in the seperator, which I removed. Ethanol was never a factor before, unless the 3 gallons left in there over winter is now affecting it. When its cold it will run for about 10-15 minutes before it dies, after that it will start right up then die a few seconds later, and just after dieing, it can be restarted right away, but then again only runs for about 5 seconds and again dies. I removed the air from the oil pump, pulled the oil pump out and tested that it pumped, installed new plugs, clean fuel filters, no water in fuel. Does this PWC have an emergency shut off when there is no oil, or if the engine gets too hot??????? I have spent end of last season and al of this season troubleshooting this issue. Please help

    PS., Thank you Beerdarter for the manuals and guides!!! I haven't looked through them yet to resolve the issue.


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Welcome to the Hulk.

    Sounds like you're filters may be plugged inside the carbs. Your fuel hoses may be kinked or deteriorating. Fuel shut off valve may be plugged. Or the fuel pump may be failing.

    If you still have the auto cok installed, you need to remove it.

  3. #3
    Quote Originally Posted by xlint89 View Post
    Welcome to the Hulk.

    Sounds like you're filters may be plugged inside the carbs. Your fuel hoses may be kinked or deteriorating. Fuel shut off valve may be plugged. Or the fuel pump may be failing.

    If you still have the auto cok installed, you need to remove it.
    Ok, I will look into fuel issues then. Fuel pumpIs it right for the oil to be dribbling from the knozzles in the carbs, or should it be squirting a little? What and where is the auto cok???

  4. #4

    Smile You Rock

    I took apart the fuel pump, and cleaned it, checked that it held 5lbs of pressure on the pulse side, blew out the lines, and checked the breathers and it runs like a champ. Thanks for the tips .

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 polaris virage,, starts for about one second ,then dies ?
    By elk river rascal in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-06-2013, 04:45 AM
  2. 90 650 runs great for 20 seconds then dies out.
    By andersonn in forum Yamaha Old School Skis
    Replies: 6
    Last Post: 07-24-2011, 12:24 AM
  3. 90 650 runs great for 20 seconds then dies out.
    By andersonn in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-16-2011, 04:36 PM
  4. 1992 Polaris SL650 Runs for 5 min then won't restart
    By bmedlock in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-20-2010, 06:50 PM
  5. 95 xp runs for 10 minutes then dies
    By 95xprider in forum 2-Stroke Performance
    Replies: 12
    Last Post: 06-09-2010, 03:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •