Results 1 to 2 of 2
  1. #1

    '96 SPX Whats draining my battery???

    Gang,

    I keep having to charge my battery if I have not run the ski for a few weeks or so..The VTS works, but the battery light on the function gauge stays illuminated all the time even if the ski is charged...Where should I start?? Thanks in advance!!!

    Scott


  2. #2
    ADAMBOMB's Avatar
    Join Date
    Mar 2006
    Location
    Sunrise,Florida
    Posts
    4,723
    +1
    196
    You could have a bad rectifier.. you can check the fuses on the MPEM.
    You could put a voltmeter onto battery the and read the voltage, then start the motor, rev it up to 5000 rpm and read the voltage again. That will tell you if the charging system is being charged or not.


    Good luck
    Last edited by ADAMBOMB; 06-21-2008 at 03:43 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. whats the cheapest battery i can put into my 951?
    By 98gsxl951 in forum 2-Stroke Performance
    Replies: 8
    Last Post: 06-06-2011, 10:27 AM
  2. What happened to my battery?!
    By tempest.runner in forum Sea Doo Open Discussion
    Replies: 20
    Last Post: 11-04-2009, 12:49 PM
  3. Guess what angle my rideplate is on?
    By philip_gpr in forum Yamaha PWC Performance (2-stroke)
    Replies: 37
    Last Post: 07-13-2008, 08:29 PM
  4. Heres What Blew My 06' Up !!!!!!!!!!
    By WATER WOODY in forum Yamaha PWC Performance (2-stroke)
    Replies: 15
    Last Post: 09-26-2006, 06:44 PM
  5. What should my rpm be??
    By DeeGee in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-15-2006, 04:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •