Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Join Date
    Jun 2008
    Location
    Spruce Grove, AB
    Posts
    34

    Unhappy High Temp Warning - Turning/Playing-Help

    Hello Everyone!!
    New to PWC's.
    I bought a 05' RXT that has close to 100hrs on it now.
    I have taken it out a couple times now but when I turn in circles playing around the Hi-Temp warning comes on, and sputters until cools off (couple seconds) then fine until you do that again.
    Is there something I should check out?

    Thanks!!!


  2. #2
    that just happened to my cousins 05 rxt and im tryn to figure it out when I get time

  3. #3
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    Quote Originally Posted by magg992001 View Post
    Hello Everyone!!
    New to PWC's.
    I bought a 05' RXT that has close to 100hrs on it now.
    I have taken it out a couple times now but when I turn in circles playing around the Hi-Temp warning comes on, and sputters until cools off (couple seconds) then fine until you do that again.
    Is there something I should check out?

    Thanks!!!
    Any mods? Sound like you got a clog somewhere

  4. #4

    Join Date
    Jun 2008
    Location
    Pasadena
    Posts
    38
    You might have sand ingestion which will clog up the cooling passages in your exhaust system. Also something to look for is the exhaust pipe going to water box from exhaust manifold. Where it does into the W.B. there are two clamps, make sure they they are right next to each other, sometimes slightly ontop of each other and all the way up on the hose. Because on that pipe there are 3 small holes tha if the clamp sits too low it'll restrict water flow in your exhaust and cause it to over heat. Also good area to pull out and check for any sand that might be blocking it? I hope your problem is just an simple fix and is nothing big!

  5. #5
    Dr Len's Son MaxMike's Avatar
    Join Date
    Oct 2007
    Location
    Barnegat Bay, NJ/ Bergen County, NJ
    Posts
    513
    are you doin 360s where that ski gets a little airborne? even though the rxt is closed loop cooled, raw water is still taken in by the grate to cool the exhaust. so if the grate i out of the water, then the exhaust is not getting cooled.

  6. #6
    THE OFFICAL SUPERDUTY!!!!!! superduty's Avatar
    Join Date
    May 2006
    Location
    Webster, Texas
    Posts
    4,726
    +1
    5
    sounds like the intercooler is clogged, and pull the j-pipe and check the exhaust tip it maybe melted

  7. #7

    Join Date
    Jun 2008
    Location
    Spruce Grove, AB
    Posts
    34
    Quote Originally Posted by MaxMike View Post
    are you doin 360s where that ski gets a little airborne? even though the rxt is closed loop cooled, raw water is still taken in by the grate to cool the exhaust. so if the grate i out of the water, then the exhaust is not getting cooled.

    It probably is cavitating a bit, would a aftermarket grate help in this??

    Thanks

  8. #8

    Join Date
    Jun 2008
    Location
    Spruce Grove, AB
    Posts
    34
    Quote Originally Posted by Alex13 View Post
    Any mods? Sound like you got a clog somewhere

    All stock, I flushed exhaust anything else to flush?

    Thanks for the help.

  9. #9
    THE OFFICAL SUPERDUTY!!!!!! superduty's Avatar
    Join Date
    May 2006
    Location
    Webster, Texas
    Posts
    4,726
    +1
    5
    Quote Originally Posted by magg992001 View Post
    It probably is cavitating a bit, would a aftermarket grate help in this??

    Thanks

    if its cavitating you need to replace your carbon seal

  10. #10

    Join Date
    Jun 2008
    Location
    Spruce Grove, AB
    Posts
    34
    Quote Originally Posted by superduty View Post
    if its cavitating you need to replace your carbon seal

    Will it not just cavitate doing spinout?
    Where is the Carbon seal? Is that the same as the wear ring?
    Sorry, I sure feel stupid with these PWC's.


    Thanks

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. High Temp Warning
    By Gforce in forum 4-Tec Performance
    Replies: 14
    Last Post: 06-23-2008, 05:41 PM
  2. High temp warning when picking up ski
    By awague2 in forum 4-Tec Performance
    Replies: 4
    Last Post: 04-21-2008, 04:12 PM
  3. High temp warning Alarm
    By qatar2000kk in forum 4-Tec Performance
    Replies: 8
    Last Post: 11-11-2007, 11:10 AM
  4. Rxdi high temp warning coming on
    By Explorer64 in forum 2-Stroke Performance
    Replies: 9
    Last Post: 05-29-2007, 11:32 AM
  5. 05 rxp high temp warning
    By outboard john in forum 4-Tec Performance
    Replies: 4
    Last Post: 06-23-2006, 01:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •