Results 1 to 7 of 7
  1. #1
    I break and lose stuff! DaBigHert's Avatar
    Join Date
    Mar 2008
    Location
    Lindenhurst,NY
    Posts
    46

    HO Pump install?

    I got a ho pump kit from y2grey(i assume it came from Carl). I'm going to install it this week. I this a cut and dry install w/ regular hand tools, or is a press required? The bearings are already installed in the pump. Thanks.


  2. #2
    Duke's Avatar
    Join Date
    Jul 2006
    Location
    Florida
    Posts
    10,004
    +1
    406
    Quote Originally Posted by DaBigHert View Post
    I got a ho pump kit from y2grey(i assume it came from Carl). I'm going to install it this week. I this a cut and dry install w/ regular hand tools, or is a press required? The bearings are already installed in the pump. Thanks.
    If you put the driveshaft in the freezer for a few hours and the pump assembly in the sun or heat it up somehow without damaging the seals you might get lucky. There is a sticky or 2 on how to do it and the correct setback for the shaft.

    A few tools but nothing special other then a set of calipers.

  3. #3
    I break and lose stuff! DaBigHert's Avatar
    Join Date
    Mar 2008
    Location
    Lindenhurst,NY
    Posts
    46
    Thanks. I saw those posts, but they were without the bearings installed. Can you explain setback to me?

  4. #4
    Duke's Avatar
    Join Date
    Jul 2006
    Location
    Florida
    Posts
    10,004
    +1
    406
    Are the seals already in the pump?

  5. #5
    I break and lose stuff! DaBigHert's Avatar
    Join Date
    Mar 2008
    Location
    Lindenhurst,NY
    Posts
    46
    I saw one seal. Is there another one?

  6. #6
    Duke's Avatar
    Join Date
    Jul 2006
    Location
    Florida
    Posts
    10,004
    +1
    406
    Should be 2 in the front. You will have to get a measurement off the back to properly set the depth. There are no stops on the shaft and it is very easy to set it to far forward. I've never done it with the bearings already in the pump.

    PM WaterWoody, I think he has done it this way a few times.

  7. #7
    I break and lose stuff! DaBigHert's Avatar
    Join Date
    Mar 2008
    Location
    Lindenhurst,NY
    Posts
    46
    Ok, maybe there are 2 in the front. There is nothing in the back. Thanks for the help, I'll try woody.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP Bilge Pump install
    By Vern in forum 4-Tec Performance
    Replies: 14
    Last Post: 08-27-2014, 10:04 AM
  2. XLT Bilge Pump Installation (Pics included)
    By PWCManiac in forum Yamaha How To & FAQs
    Replies: 8
    Last Post: 08-02-2011, 07:35 PM
  3. RXP bilge pump install
    By The Bandit in forum Sea Doo Open Discussion
    Replies: 73
    Last Post: 08-07-2007, 06:41 PM
  4. 2005 Pump Install
    By NateGP1300R in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 07-03-2007, 07:31 AM
  5. Pump install question.
    By Mark S in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-01-2005, 09:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •