Results 1 to 9 of 9
  1. #1

    Join Date
    May 2008
    Location
    North Dakota
    Posts
    32

    92 SL650 Cooling System Routing

    I've got a 1992 SL 650 and have a question on the current routing of the cooling system. I got my hands on the service bulletin on the cooling system for that year but after looking at it I have even more questions. I've attached a picture trying to show the current routing of the cooling system, it looks like a combination of the 1993 & 1992 cooling system. My main question is this set-up correct or should it be changed for better flow? The engine is being rebuilt and after teardown most of the bottom cooling hoses were plugged with sand and the mag cyclinder looked like it was just about ready to burn a hole through the piston. So I would like to make sure that the cooling system is hooked up in the most effecient way to keep everything working. Any info would be greatly appreciated.
    Attached Files Attached Files


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    I would just clean and inspect all hoses and keep them as is.

    The holed piston has nothing to do with cooling problems. But more of a fuel starvation issue.

    Cooling probs result in seized pistons and scored cyl walls.

  3. #3

    Join Date
    May 2008
    Location
    North Dakota
    Posts
    32
    So the routing seems to be correct or atleast it shouldn't cause any issues?

    All the hoses have been inspected and cleaned and then reassembled. What would be the thing to look for to make sure the water is flowing properly?

  4. #4
    the 3 from the manifold are supposed to go th the 3 in the fitting at the loop from the block! unless your running newer heads that dont have the cooling into the block so I'm not altogethe sure what is going on with yours? or how it will work
    Last edited by ZMANN; 06-25-2008 at 11:42 AM.

  5. #5

    Join Date
    May 2008
    Location
    North Dakota
    Posts
    32
    Quote Originally Posted by ZMANN View Post
    the 3 from the manifold are supposed to go th the 3 in the fitting at the loop from the block! unless your running newer heads that dont have the cooling into the block so I'm not altogethe sure what is going on with yours? or how it will work
    Everything is still stock so there is water going to the cases. This is where I'm confused that the actual 1992 diagrams shows each outlet from the manifold going to each fitting in the block. But from the service bulletin on the cooling system for that year it does identify a change but it doesn't show a diagram of it should look afterwards or atleast I can't seem to find it. So my dilemia is did the previous owner do this correctly or is it a formula for future problems.

  6. #6
    the cooling mod didn't have anything to do with bypassing the manifold fitting as far as I remember? I have a 92 also and I ran the stock cooling until I went with 750 cyl's then I had no case cooling and just disconnected the lower hoses and looped the upper manifold hoses

  7. #7

    Join Date
    May 2008
    Location
    North Dakota
    Posts
    32
    Quote Originally Posted by ZMANN View Post
    the cooling mod didn't have anything to do with bypassing the manifold fitting as far as I remember? I have a 92 also and I ran the stock cooling until I went with 750 cyl's then I had no case cooling and just disconnected the lower hoses and looped the upper manifold hoses
    ZMANN,
    Did you ever have any issues of over heating when you were running it as a stock 650?

  8. #8
    do you still have the 650 and how did you fix the problem

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,572
    +1
    1,272
    Quote Originally Posted by dtm79 View Post
    do you still have the 650 and how did you fix the problem
    Welcome

    Rather than trying to resurrect a 5 year old thread, I suggest you create a new thread in the Polaris Open Discussion forum.

    Introduce yourself and your machine. Include details on what the problem is, and what maintenance and diagnostics have been done recently.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 03-07-2016, 08:13 PM
  2. closed vs open loop cooling system
    By Tiplickhahaha in forum 4-Tec Performance
    Replies: 31
    Last Post: 03-08-2015, 10:53 AM
  3. need help on a yamaha xl700 cooling system routing
    By upchuckk in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 09-27-2008, 08:37 PM
  4. 05 GTX 4tec SC Cooling System Issue
    By jetworx hawaii in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 05-28-2006, 01:18 PM
  5. Hulk, Flushing Closed-Loop cooling system
    By Red Devil in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-12-2005, 09:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •