Results 1 to 6 of 6
  1. #1
    otnielarencibia's Avatar
    Join Date
    Apr 2007
    Location
    Pompano, FL
    Posts
    38

    help start my f-12x

    I started my Honda about 2 months ago with no problem. I changed the oil yesterday and now it won't start. It cranks with no problem and the motor turns over but it doesn't start I tried charging the battery but no luck. I tried searching the forums but couldn't find anything. I need the ski for this weekend since I am going to the beach for a week and I want to take the Honda. Thanks


  2. #2

    Join Date
    Jul 2007
    Location
    fontana ,ca
    Posts
    69
    check the fuses first. then check for spark. if you have spark, then listen for the fuel pump. it should activate for 3 seconds when the key is first installed. if you here the pump and you have spark, spray carb cleaner into the intake manifold through the gray hoses. if it starts, then either the fuel pump, or injectors are bad. if after that it does not start, pull the codes off the unit if any are there.

  3. #3
    otnielarencibia's Avatar
    Join Date
    Apr 2007
    Location
    Pompano, FL
    Posts
    38
    Fuses are good. Fuel pump does turn on. I will check for spark. Into which hoses do I spray car cleaner? And I know its on here but my search function doesn't work so... How do I pull the codes?
    Thanks

  4. #4
    spatera's Avatar
    Join Date
    Jul 2007
    Location
    S. Georgia
    Posts
    127
    Are you getting any FI or beep codes to pull? I have a spare ECM I could let you try but I think they changed in 04 and mine is for a 02. If it's not that, I don't know of any sensors that would stop it from running completely other than the low oil pressure. Even though you said the fuel pump is working, do you know if it has pressure.

  5. #5
    otnielarencibia's Avatar
    Join Date
    Apr 2007
    Location
    Pompano, FL
    Posts
    38
    Quote Originally Posted by spatera View Post
    Are you getting any FI or beep codes to pull? I have a spare ECM I could let you try but I think they changed in 04 and mine is for a 02. If it's not that, I don't know of any sensors that would stop it from running completely other than the low oil pressure. Even though you said the fuel pump is working, do you know if it has pressure.
    I don't know if the fuel pump has pressure. How would I check that? The only thing that lights up is the battery light.

  6. #6
    otnielarencibia's Avatar
    Join Date
    Apr 2007
    Location
    Pompano, FL
    Posts
    38
    Well I got it started wi a new battery and new spark plugs. Thanks guys!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. HELP: when I start my ski on trailer it rev's straight to WOT w/out pulling throttle!
    By gmoeller in forum Kawasaki PWC Performance (4-stroke)
    Replies: 20
    Last Post: 07-06-2015, 04:22 PM
  2. Replies: 1
    Last Post: 06-14-2015, 07:02 PM
  3. More help on my GPR....Now intermittent starting!
    By ramairformula74 in forum Yamaha Open Discussion
    Replies: 6
    Last Post: 07-17-2009, 09:30 AM
  4. Having problems starting my 900 STX after carb cleaning, HELP PLEASE???
    By Bala in forum Kawasaki PWC Performance (2-stroke)
    Replies: 1
    Last Post: 05-10-2008, 06:03 PM
  5. HELP on diagnostic memory reset on my f-12x
    By timmy_philson in forum Honda How To & FAQs
    Replies: 2
    Last Post: 09-23-2007, 08:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •