Results 1 to 3 of 3

Thread: Battery Issues

  1. #1

    Join Date
    Jun 2008
    Location
    Warren, OH
    Posts
    42

    Battery Issues

    I am having starting issues with my sl900. I have a brand new battery, and with a full charge, i get a reading of 10.4-10.6v at the battery when starting. I am pretty sure that is too low, and i have tried two seperate batteries. Any ideas whay this is occuring or anything else to check? Maybe i should should try a booster? Is a regular automotive booster too big?


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    If you're talking something like this, yeah I use them ALL the time.
    10.6 measured at the battery while cranking should be enough but try the jumper and see how you fare.
    If you still get no spark, test the stator.
    Last edited by ph2ocraft; 06-25-2008 at 11:42 AM.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by rcngmoto View Post
    I am having starting issues with my sl900. I have a brand new battery, and with a full charge, i get a reading of 10.4-10.6v at the battery when starting. I am pretty sure that is too low, and i have tried two separate batteries. Any ideas why this is occurring or anything else to check? ...
    Either both your batteries are not in good shape, or the starter is pulling too much current, or you have a poor electrical connection at one of the heavy battery cable ends.

    Clean and check them all, especially both ends of the positive cable from the battery to the starter solenoid.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. battery issue solved
    By bossdog67 in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 10-18-2009, 04:39 PM
  2. SLX 750 battery issue
    By jddesign in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-09-2009, 08:47 PM
  3. RXPX Battery Issue/Question
    By RXTJeff in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 07-04-2008, 12:54 PM
  4. Battery issue
    By polarispa in forum Polaris Open Discussion
    Replies: 1
    Last Post: 04-20-2007, 01:15 PM
  5. Battery issue
    By fastkaz in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 02-19-2007, 10:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •