Results 1 to 4 of 4
  1. #1
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237

    Re-Installing impeller/pump

    I noticed after I tightened down my impeller that it does not spin freely, it spins.. just not free..Can you overtighten an impeller? I'm thinking that it's normal, just wanted to check before I mess this thing up.

    Thanks,

    Alex


  2. #2

    Join Date
    Nov 2006
    Location
    NC
    Posts
    361
    Did you install a new wear ring ? If so its just scrubbing that and will wear in first start up.

  3. #3
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Alex,When i install mine they do not spin "freely" there is a little bit of resistance but not alot.as long as you torqued it down to 92 foot Lbs you should be OK..If it is real hard to spin then there is a problem....

  4. #4
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    Quote Originally Posted by Snoman View Post
    Alex,When i install mine they do not spin "freely" there is a little bit of resistance but not alot.as long as you torqued it down to 92 foot Lbs you should be OK..If it is real hard to spin then there is a problem....
    Thanks! There is a little resistance but not alot, so ...Cool

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How to remove and re-install the Polaris 148mm jet pump
    By K447 in forum Polaris How To & FAQs
    Replies: 27
    Last Post: 09-22-2015, 10:11 AM
  2. Sealing pump and installing impeller this weekend. Any tips?
    By yamadood in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 03-11-2011, 07:37 PM
  3. 05 R-12x Pump re-install question
    By cigarlust in forum Honda How To & FAQs
    Replies: 1
    Last Post: 07-31-2009, 06:12 PM
  4. re-installing impeller
    By gorilla03 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 07-27-2007, 12:02 AM
  5. re-installation of the pump
    By BlaZinMJ in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-04-2007, 02:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •