Results 1 to 7 of 7
  1. #1

    Join Date
    May 2008
    Location
    Austin, TX
    Posts
    14

    Slow 07 Ultra - What to try next?

    First off, thanks everyone for all the great info in the forums. I've been reading for about a month and doing some tweaking but I feel I still have some room to go before I get to average speeds on for my 07 Ultra. My top speed gps is 64.7 (1 bar) with 61-63 mph the norm. I have the following mods: Riva Ride Plate, Riva Sponsons. Pump seal, BOV blockoff, and the valve cover block off. I bought it used at 10 hours and have since taken it up to 31 hours. Compression was tested good at 10 hours. I have the ‘normal’ gas in oil issue but that has gotten better since installing part of the OCMS kit (blocked off drain into pan). Max rpms are around 7740. Before the BOV blockoff I was going 1-3 mph slower and only around 7550 rpms. I keep the oil fill level low as suggested. Local air temps are upper 90s to 100. Water temp is around 78-79. Also, I’ve cleaned out the intercooler and did remove some buildup but gained nothing in terms of performance. The engine runs smooth – so I’m not suspecting the plugs but they have not been changed. Any ideas on what to try next? Thanks!
    Last edited by ph2ocraft; 07-15-2008 at 08:31 PM.


  2. #2
    Silence! I Keel You! earthshaker's Avatar
    Join Date
    May 2007
    Location
    Northern CA Coast
    Posts
    1,616
    +1
    2
    Welcome to GH Paul!

    Have you done anything to help get fresh air into the hull, or hot air out?

  3. #3

    Join Date
    May 2008
    Location
    Austin, TX
    Posts
    14
    To date I haven't done anything but later today I am installing the flat filter under the glove box. Hopefully this will let it breathe a little better but I'm a little concerned about ingestion.

  4. #4
    Silence! I Keel You! earthshaker's Avatar
    Join Date
    May 2007
    Location
    Northern CA Coast
    Posts
    1,616
    +1
    2
    Are you running the factory intake silencer and have you capped the port where your BOV line was hooked up to?

    I have no doubt that water will get inside the hull through the filter if you take water over the bow, but keeping it out of the intake is the critical part.

  5. #5

    Join Date
    May 2008
    Location
    Austin, TX
    Posts
    14
    I'm running the factory air intake box. I'll be caping off the BOV input to the airbox as part of the flat filter install. After I do this and do a test run I'll post back the results. Thanks.

  6. #6

    Join Date
    May 2008
    Location
    Austin, TX
    Posts
    14
    I have the flat filter installed now. I have the BOV air hoses capped off. It was hard to get a good number on my run as it was very hot; 100 degree air and 82 degree water also very windy with a lot of chop. Anyway, got to 64.3 gps. This speed was more consistent than my previous speeds. RPMs where slightly better up to 7810. Overall responsiveness was much better. I see from other threads others are getting similar performance and then yet others are in the upper 60's. Thoughts?

    BTW, for those that haven't installed the flat filter, the noise increase is very noticeable. My wife commented after her ride asking what I had done... I think it's not too bad and we both will get used to it after a few rides.

  7. #7
    sportman's Avatar
    Join Date
    Mar 2008
    Location
    Abu Dhabi-UAE
    Posts
    333
    I guess Riva Sponsons will slow u down, check with stock ones and record the results your rpm and top end speed (GPS)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Got the Ultra disease..What to mod next?
    By Prof100 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 20
    Last Post: 10-14-2016, 10:39 AM
  2. 94 Sl750 not cranking, what to try next?
    By classic1275cc in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 08-19-2016, 07:27 AM
  3. SPX 800 (787 engine) will not crank... what to try next?
    By DKFox in forum 2-Stroke Performance
    Replies: 15
    Last Post: 07-17-2009, 05:39 PM
  4. What to do next?
    By dropped in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-29-2006, 01:21 PM
  5. What to do next???
    By SpeedStang95 in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 07-03-2006, 05:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •