Results 1 to 9 of 9
  1. #1

    95 SL750 wont idle

    So i have had this problem for about a year now and i cant seem to find out the solution. My sl750 wont idle. I have rebuilt the carbs and set to factory setting. I have replaced the stator and spark plugs. I have changed out the fuel lines and i cant figure out why it dies under 3000 rpms. I do know the guy i bought it from had put in another fuel pump and had different jets in it, but not sure of the size. Was wondering if anyone had any ideas of what to check next. Also when i stay on the throttle and let it run i checked the spark plugs afterward and the are black and wet. Does this mean it is running to rich. I have the carb at factory settings but i was thinking with the jetting that it could be taking on to much gas and not leaving room for combustion in the engine and it would cause it to die. Let me know if you know anything


  2. #2
    la90043's Avatar
    Join Date
    Oct 2006
    Location
    Los Angeles
    Posts
    1,201
    its probably the jets....................you know if you were to read piston wash on each piston that will definitely let you know how rich it is running and if the jets were the corporate.

  3. #3
    so try a set of factory jets than

  4. #4
    la90043's Avatar
    Join Date
    Oct 2006
    Location
    Los Angeles
    Posts
    1,201
    yes, i would put back in the stock factory jets for them carbs to that pwc.

    the motor is stock right?

  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    It's possible the needle and seats are worn and leaking, the wrong size (too big), or maybe the pop off springs are worn or too light.

  6. #6
    I replaced the popoff springs with no luck and i used the 80 gram factory springs. I am going to order the jetting for it should a use the factory 75p and 90m or should i go something different

  7. #7
    la90043's Avatar
    Join Date
    Oct 2006
    Location
    Los Angeles
    Posts
    1,201
    i dont know what the pop off pressure should be on your boat but it should be set at its correct tolerance......................

    yup put in stock jets................that's probably the problem right there.......the ones in there are probably too big.........too much fuel.............................

  8. #8
    so i put the factory jets in and still it wont idle less than around 2800 rpms and this is hooked up to hose. I am running out of ideas on what it could be.

  9. #9
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    Mine idles at 2900 out of the water. 1250 in the lake. The pump drag will tell you wherre you stand

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 95 SL750 wont start
    By buffalomoz in forum Polaris PWC Performance
    Replies: 2
    Last Post: 07-11-2015, 08:06 PM
  2. 95 wave venture idles, wont go over 7mph. Help!!
    By Larry 597 in forum Yamaha Old School Skis
    Replies: 4
    Last Post: 08-17-2009, 03:59 PM
  3. SL750 Safe/95 SL750 Limp home mode. Runs, but barely over idle.
    By armyguy7776 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 07-01-2008, 04:11 PM
  4. 95 SL750 wont idle
    By jdsparks21 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 05-11-2008, 09:43 PM
  5. Towing '95 SL750 ?
    By dorf in forum Polaris How To & FAQs
    Replies: 19
    Last Post: 07-20-2007, 11:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •