Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    jack's Avatar
    Join Date
    Jun 2005
    Location
    West Palm Beach Florida
    Posts
    712

    Speedometer Not Working

    I took my brand new RXP out for the first time today. The speedometer does not work at all. Is this something I should just take back to the dealership or should I try to fix it myself? If so can anyone tell me what to look for and then how to check it other than taking it on the water?


  2. #2
    R.I.P. 11's Avatar
    Join Date
    Apr 2005
    Location
    Santa Monika, People's Republik of Kalifornia...
    Posts
    1,571
    +1
    1
    That is not a big loss, speedos are useless, get a GPS...

  3. #3
    jack's Avatar
    Join Date
    Jun 2005
    Location
    West Palm Beach Florida
    Posts
    712
    11, I have a gps but I dont need to be that accurate and I haven't mounted it. Besides, it is a brand new ski and it should be working.

  4. #4
    R.I.P. 11's Avatar
    Join Date
    Apr 2005
    Location
    Santa Monika, People's Republik of Kalifornia...
    Posts
    1,571
    +1
    1
    I am sorry I just hate speedos, after all, I wouldn't wear a watch that doesn't give me the right time, but that's just me...

  5. #5

    Join Date
    Jun 2005
    Location
    near detroit michigan
    Posts
    299
    by the back of the boat with the cowel off you can find the wiring for the speedo follow it foward and make sure it is pluged in (I bet it is unpluged)

  6. #6
    RM_RXP's Avatar
    Join Date
    Apr 2005
    Location
    "Sweet Home Alabama"
    Posts
    62
    It could be something as simple as the speedo "wheel" not turning freely. A small piece of grass can clog the wheel and prevent it from turning.
    If not, I agree with Krazy-K. Regardless, it is probably something simple

  7. #7
    jack's Avatar
    Join Date
    Jun 2005
    Location
    West Palm Beach Florida
    Posts
    712
    I took the seat off, and looked with a flash light and didnt see any unplugged wires, I really am not sure where it is on the boat. Do I need to take the plastic off that the seat is on? Then look further back?

    WHere is that wire? I dont have any manuals other than the owners manual.

  8. #8

    Join Date
    Jun 2005
    Location
    near detroit michigan
    Posts
    299
    take the seat cowling off and look outside the boat in the back on the right side of the ski you will see the little wheel by the bottom,inside the boat directly inside from that will be wiring that goes to the back of the motor area on the right side of the engine that is the wire follow it and see if it is pluged in.

  9. #9
    jack's Avatar
    Join Date
    Jun 2005
    Location
    West Palm Beach Florida
    Posts
    712
    Thanks Krazy-K,
    Just want to ask silly question. Is the cowling you are talking about, the black plastic that the seat rides on? It is held on by allen bolts (4 i think) and the coolant is attachted to it.

    If that is it do I locktite it when I put it back on? If so what loctite do I use?

  10. #10

    Join Date
    Jun 2005
    Location
    near detroit michigan
    Posts
    299
    Yes,that is the cowel.No I dont locktight those bolts.thire are 5 bolts,the 4 you see and 1 under the black rubber cap under the grab handel,the 2 bolts under the seat 2 the rear just need to be loosened then it will stick you will have the give it a pull.thier is also a thred in the (rxp tech section of thei forum)giving good directions and pics I think

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Speedometer not working
    By blkvette in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 09-09-2010, 02:39 PM
  2. MPH/Speedometer Not Working
    By rickreeves1 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 07-24-2009, 10:25 PM
  3. new RXP-X speedometer not working on my machine
    By davidescu_radu in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-06-2008, 04:36 PM
  4. 2003 STX Di speedometer not working
    By emcewin in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 05-19-2008, 09:34 AM
  5. 1999 genesis ficht speedometer not working
    By wmwbutler in forum Polaris Open Discussion
    Replies: 4
    Last Post: 09-04-2007, 12:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •