Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Polaris SLT 780 97 model

    I don't know if Iím posting this in the right place but here goes. My SLT 780 was running great and then it started to bog sporadically. Then it would not even plane off. Iíve had this problem before and changing the spark plugs did the trick. This time I changed the plugs and caps (NGK TB05EMA) because it had apparently been arcing pretty badly. What gap do I need for the plugs (NGK)?

    Do you guys think it is in limp mode for some reason? The display shows full fuel and oil.

    Any help would be greatly appreciated. I am going to drop it in the lake right now and will have some updated info shortly. Thanks for your help!


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    Welcome to the Hulk!

    All spark plug info is in the 1992-1998 Service Manual.

    Do you have a RED warning lamp on the MFD?

    If not, then it shouldn't be in limp mode.

  3. #3
    Ok, the center cylnder is not firing but I'm getting spark. I do not have a red light on the display except when it first starts (it blinks a few times). Thanks for the quick reply!

  4. #4
    I checked the cylinder pressure and the outside ones had 125 psi. The center had zero, big goose egg. What the heck should I do know? I guess I need to start disassembling this thing. Any advice would be greatly appreciated. I know Polaris stopped making watercraft so am I going to have a lot of trouble finding parts?

  5. #5

    Join Date
    Jun 2008
    Location
    Warren, OH
    Posts
    42
    There are alot of great people on here who can direct you to a part, so at this point dig in and see if you cant find your problem, then decide what your going to need.

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    Quote Originally Posted by Lazy View Post
    I checked the cylinder pressure and the outside ones had 125 psi. The center had zero, big goose egg.
    What the heck should I do know?
    I guess I need to start disassembling this thing.
    Any advice would be greatly appreciated. I know Polaris stopped making watercraft so am I going to have a lot of trouble finding parts?
    Parts are not a problem. Both new and used Polaris brand parts are available, plus several aftermarket sources.

    Refer to the Service Manual, and do some searching and reading of relevant older threads on here. Lots of people have had similar troubles.

    You will be removing the cylinder head for the middle cylinder. That will allow you to see and determine the condition of the piston and cylinder walls.

    My guess is that you will find a damaged piston. Post some clear photos of what you find, and we can guide you along.

    In addition to fixing whatever mechanical damage has occurred, you will need to correct the cause of the problem.

    The most common cause is fuel system issues, or carburetors that needed cleaning, and the cylinder was running with weak fuel delivery, causing lean burn, high piston temperatures, and engine damage.

    Since the other two cylinders were still operating, it is common to not notice the change in engine performance until the piston completely fails.

  7. #7
    What do you folks think about this damage? Do you think I can replace just the piston and rings or do you think the cylinder needs to be replaced? Is it possible to be notified by email when someone replies to this post?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	100_1598.JPG 
Views:	173 
Size:	678.4 KB 
ID:	81963   Click image for larger version. 

Name:	100_1601.JPG 
Views:	122 
Size:	840.2 KB 
ID:	81964  
    Last edited by Lazy; 07-08-2008 at 03:06 PM.

  8. #8
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Man you are lean!!!! You will need to pull the cylinder and check the condition and measurements.

  9. #9
    Feral's Avatar
    Join Date
    May 2008
    Location
    Georgetown, Ontario
    Posts
    216
    Subscribe to your own thread it will email you when theres new posts..

    Show us your other 2 cylinders so the guys here can judge them on if there running lean or rich aswell....
    this will help them on comming to conclusions if its a carb , fuel pump, line delivery problem

  10. #10
    I took my 780 to a guy who was recommended by my father-in-law. I want to know if you guys think he is competent. I told him what I already knew and he said itís possible that the hose for oil delivery to the center carb may have popped off. He also said he would fill the engine (I guess the bottom end) with very thin oil to check some seal to see if it will be worth it to fix this engine(he may have been talking about a seal between cylinders). He recommended removing the oil injection system and mixing the gas manually from now on. He said the only reason the injection system was there was for emissions regulation and that the ski ran at 100:1 when idling cold out of a long no wake zone. He's not saying that is what caused this problem, it's just an argument against the oil injection system.


    So what do you think?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 Polaris Slt 780 Cylinder size?
    By Ghostrider55 in forum Polaris How To & FAQs
    Replies: 20
    Last Post: 08-07-2015, 10:45 AM
  2. 2 97 Polaris SLT 780's whit problems please help. New to pwc world
    By greynosa in forum Polaris How To & FAQs
    Replies: 18
    Last Post: 06-12-2015, 11:09 PM
  3. New Owner - '97 Polaris SLT 780
    By RMFCSLT in forum Polaris PWC Performance
    Replies: 19
    Last Post: 08-24-2014, 07:47 PM
  4. Parting out or sell whole 97 polaris slt 780
    By dustin88 in forum Polaris Classifieds
    Replies: 14
    Last Post: 06-03-2009, 09:55 PM
  5. 97 Polaris SLT 780
    By krirish in forum Polaris Open Discussion
    Replies: 13
    Last Post: 06-02-2007, 08:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •