Results 1 to 2 of 2
  1. #1

    Join Date
    May 2008
    St Paul, Mn

    losing oil out of drives on both 98 & 99 GTS


    I need some help, I am losing oil out of both drives on my GTS's. I fill them to the top, and they go down in no time at all. There still is some in there, but not full to the top from when I started. Is this normal? or do I have to replace seals in the drives? Any help would be great, thanks again.

  2. #2
    KEN G's Avatar
    Join Date
    Aug 2005
    Cherry Hill NJ
    When you say "drives" i'm assuming you mean pumps. Yes either your cone is not sealing or the seal is shot or both. I used to pressure test my pumps with a pop off pump/ tester.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2007 stx12f blowing oil out the overflow ?
    By chris alix in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 07-18-2010, 11:37 PM
  2. Help- i just blew all of the oil out of my motor
    By pdxrealtor in forum 4-Tec Performance
    Replies: 12
    Last Post: 08-04-2009, 01:37 AM
  3. RXP still blowing oil out catch can
    By mstennes in forum 4-Tec Performance
    Replies: 19
    Last Post: 07-16-2009, 08:03 PM
  4. Just pumped a gallon of oil out of my motor
    By super_gtx in forum 4-Tec Performance
    Replies: 8
    Last Post: 08-08-2008, 12:07 AM
  5. black oil out back
    By levonhelmet in forum 2-Stroke Performance
    Replies: 4
    Last Post: 03-23-2008, 06:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts