Results 1 to 4 of 4
  1. #1

    Slt 750 wont stay running

    I have a 1994 slt750 that dies after a wot run. If you run wot for a few minutes and let off it will die, kinda like it is loading up. After it dies it will fire up as soon as you hit the starter but at all times you have to ease into the throttle even when it is acting fine. After about 1/3 into the throttle it picks up and runs fine. Any help is greatly appreciated. Also what type of oil should I run.

  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Cleveland OH
    Welcome to the Hulk.

    You need to verify it's loading up. Take a plug wrench with you next time it happens and remove a plug. Is it wet?

    It may be overheating, so I'd check cooling hoses to be safe.

    TWC III oil is what's called for in these 2 strokers.

  3. #3
    Join Date
    Jul 2007
    Cedar Rapids,Iowa
    Let's go back a little,Can you drop it into the water and take off normal and run mid range with no problems? Does it only die after a WOT run?
    After a restart,and you feather up to speed,will it run except WOT?

  4. #4
    I am sorry, I dont know why i said loaading up. It actually acts like it is running out of fuel. It starts losing rpm and if you let off as soon as it starts doing it, it will idle for a minute and then you can go again. But I still dont know why it is so doggy until you reach 1/3 throttle. Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Virage TXI wont stay running DI
    By ncdoo in forum Polaris Open Discussion
    Replies: 17
    Last Post: 05-23-2012, 09:43 PM
  2. Fuel pump wont stay running
    By bandit82184 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 03-27-2010, 08:14 PM
  3. 650 wont stay running
    By sammy64 in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 08-31-2009, 02:08 PM
  4. Replies: 7
    Last Post: 04-14-2009, 09:22 PM
  5. 95 slt 750 wont charge
    By The Joker in forum Polaris How To & FAQs
    Replies: 8
    Last Post: 12-13-2006, 03:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts