Results 1 to 1 of 1
  1. #1
    nicjak's Avatar
    Join Date
    Mar 2008
    Warragul, Downunder

    Thought i never had a GIO Problem until!!

    Guys just to let you know i like many thought i never had a GIO problem until i changed my oil on the weekend. first oil change i done was at 10hrs and i know i put in 4.3qrts. Oil was getting very smelly so i decided to do a change at 33hrs i pulled out 4.5-6qrts. It was very black and had a very strong gas odour. What i have found it is so hard to get any consistant dipstick reading. if i place the dipstick loop to the left i get a high reading if i place it to the right it is more realistic i am know believing this may be the correct postion. I will be much happier now with my catch can mods.
    come to the belief we all have it.
    Last edited by nicjak; 06-29-2008 at 09:13 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. More GIO problems
    By rathee in forum Kawasaki PWC Performance (4-stroke)
    Replies: 16
    Last Post: 05-22-2008, 05:58 PM
  2. massive air leak-but never had aproblem-WHY?
    By Mongoose in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 12-16-2007, 01:15 PM
  3. never had this happen
    By LANCE in forum Polaris How To & FAQs
    Replies: 37
    Last Post: 09-23-2007, 04:12 PM
  4. Replies: 8
    Last Post: 09-01-2007, 07:14 PM
  5. Well, I had a big problem with my Ski this Weekend...
    By LiquidDI in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-20-2007, 10:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts