Results 1 to 2 of 2
  1. #1
    Goliath's Avatar
    Join Date
    Jun 2008
    Location
    Morehead City, NC / Stow, OH
    Posts
    758

    Throttle Problems...

    I took my 2000 GP1200R out today and it ran GREAT!! When I got home I hooked up the hose to flush it out. When I started it the engine reved up like it was on full throttle. I turned it off immediately and inspected the throttle cable. I found out that when I pull the throttle it is fine, but the wheel turns very slow going back the other way. I tried spraying some white lithium grease on it, but I think the problem is on the bottom of the wheel. Has anyone ever heard of this problem before?

    I Also wish that everything wasn't so packed in there. I can't fit the grease can in between the the exhaust and the cylinders to spray on the under side of the wheel!!!
    Last edited by Goliath; 06-30-2008 at 01:52 PM.


  2. #2
    Goliath's Avatar
    Join Date
    Jun 2008
    Location
    Morehead City, NC / Stow, OH
    Posts
    758
    Never mind I read in the manual that you have to lubricate up by the handle bars...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 xp throttle problem
    By cman071 in forum 2-Stroke Performance
    Replies: 3
    Last Post: 04-17-2009, 09:17 PM
  2. Throttle problems/ need help
    By 95SLT750PWC in forum Polaris Open Discussion
    Replies: 2
    Last Post: 08-19-2008, 08:53 PM
  3. SLT 780 Full Throttle Problems
    By shkdwn387 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-25-2008, 10:54 AM
  4. Throttle Problem
    By jem in forum Sea Doo Sport Boats
    Replies: 6
    Last Post: 11-20-2007, 10:13 PM
  5. Help finger throttle problems
    By jonjonwells in forum Polaris Open Discussion
    Replies: 8
    Last Post: 04-20-2007, 02:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •