Results 1 to 4 of 4

Thread: help fast

  1. #1
    Ya Boy Trevor bajaeater's Avatar
    Join Date
    Dec 2005
    Location
    Tampa
    Posts
    1,083
    +1
    19

    help fast

    hey guys,
    got a problem from mudbug i thought was fixed but now im not sure. Ski doesnt want to start. Sounds like a week battery. Duke said he thought my advent wasnt changing timing when I went to start it so it was struggling. Found out I had a bolt missing and a bolt really loose that holds the three pieces of the starter together. the long bolts. Theres only two of them and there part 12 in the starter section of oem parts. i tightened one at mudbug cause couldnt find the other and it randomely started. I tried it out of water and it started when I got home. So i thought it was just the bolts but today it wouldnt start turn to find out the one bolt was loose again so I tightened it and it started but didnt sound fully strong but not noticable to untrained ear. i think its cause other bolts missing but I dnt get it until friday and I leave friday so I may need an advent b4 then. I dnt have a spare ski like this cause If I did Id just loosen the bolts and see what it does. What do you all think it is? I dnt have a spare ignition either. HELP. Im going nuts.


  2. #2
    what do you need? an advent or the starter bolt or? I can at least get u a measurment for the bolt if that helps? sry you lost me

  3. #3
    Ya Boy Trevor bajaeater's Avatar
    Join Date
    Dec 2005
    Location
    Tampa
    Posts
    1,083
    +1
    19
    well i did have a thread up to get the bolt or size but no one could come threw but now I got one on the way. I dnt know if the bolt missing is the problem or if it is my advent. I need to know if anyone knows what it is or if someone has a spare advent I can borrow to figure the problem if know one knows.

  4. #4
    Gotcha! I got to say knowing the e internals of a starter , a loose housing will do some weird thing to brushes etc I would bet this is your issue but it may clear up when the brushes re seat , I saw your original bolt post now that u mentioned it but I didn't have access to my spare starter then sry

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need Help Fast
    By yami_rida#26 in forum Yamaha How To & FAQs
    Replies: 4
    Last Post: 05-10-2008, 07:59 PM
  2. MFD HELP FAST Please help.
    By tiger0432 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-28-2007, 04:45 PM
  3. broken mfd need help fast
    By slpolaris in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-18-2007, 08:47 AM
  4. Need some HELP FAST!!! for mechanic!
    By NeverEndn in forum 4-Tec Performance
    Replies: 9
    Last Post: 05-25-2007, 04:55 AM
  5. Wear ring ? need help fast!!!!
    By NeverEndn in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-08-2006, 01:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •