Results 1 to 9 of 9
  1. #1
    rx4pain's Avatar
    Join Date
    Apr 2005
    Location
    Olympia, WA
    Posts
    1,929
    +1
    1

    Anyone have the RR IC install instructions?

    I left the one that PPG sent to me at work. Can't remember if SD.net or somewhere on here as a link or instructions?

    Thanks!


  2. #2
    rx4pain's Avatar
    Join Date
    Apr 2005
    Location
    Olympia, WA
    Posts
    1,929
    +1
    1
    Decided to drive into work and get them...if anyone has any hints or suggestions, I'll be diving into this today and tomorrow.

  3. #3
    rx4pain's Avatar
    Join Date
    Apr 2005
    Location
    Olympia, WA
    Posts
    1,929
    +1
    1
    Thought I'd respond to myself again since I've had one too many beers. I have to say, that billet aluminum plug sucks ass! I've tried everything from KY (not Kentucky) to freezing it just to get it in far enough to get the clamp over it. What's the trick? And that stock IC hitting the gas tank was not an issue for me. It was hitting the stock airbox and not coming close to the gas tank.

  4. #4
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2
    Get it into place, then take a rubber mallet and use both hands to tap it in. You need both hands on the mallett because you don't have the clearance to hit it very hard.

  5. #5
    rx4pain's Avatar
    Join Date
    Apr 2005
    Location
    Olympia, WA
    Posts
    1,929
    +1
    1
    Okay, so I try using a hammer wrapped in a towel because I could get more room with the hammer than my rubber mallet. It would sink one side and then pop out when you tried to even it out. I gave up and froze it but that didn't work so I started working on the power pipe and IC bracket. I'm done for tonight.

  6. #6
    rx4pain's Avatar
    Join Date
    Apr 2005
    Location
    Olympia, WA
    Posts
    1,929
    +1
    1
    Oddly enough, I switched the "O" ring and used the other "O" ring from the rear of the stock IC and the plug slipped right in and fit like a glove. I swear I spent an hour on trying to hammer that thing in...

  7. #7
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2
    It is a pain in the ass. Watch it closely for a little while. The o-ring I originally used went in easy, but it came loose at some point and dissappeared. The next o-ring was a bitch to get in, but it gives me comfort knowing it is in there tight.

  8. #8
    rx4pain's Avatar
    Join Date
    Apr 2005
    Location
    Olympia, WA
    Posts
    1,929
    +1
    1
    Wow...I'll be sure to check it periodically.

  9. #9
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,009
    +1
    49
    jerry didnt you have these on a file, did a search and cant find them..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Anyone have the Polk Ausdio db651,s?
    By Water4fire in forum Sea Doo Sport Boats
    Replies: 6
    Last Post: 06-18-2007, 12:01 PM
  2. Anyone have the Sprint Fusic phone...?
    By GeoRXT in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 11-22-2006, 01:58 PM
  3. Anyone have the video of the Snowmobile vs. Jetski
    By Kinchyle in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-01-2006, 04:40 PM
  4. Anyone have the Riva bar extensions/finger throttle kit?
    By Green Hulk in forum 4-Tec Performance
    Replies: 38
    Last Post: 01-26-2006, 11:21 PM
  5. Sponsons Anyone have the R&D? How do they compare?
    By Water4fire in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-03-2005, 09:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •