Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1

    Blown SC! Any Help???

    Well not sure where to start, but about 2 weeks ago a friend had some stuff caught up between the prop and the wear ring! cleaned it out and took the ski for a ride not suprisingly i had no holeshot power no topend so we figure it was the ring..this is the 3rd ring we replaced since we owned the ski or better yet since he owned it! its a 05' rxp!...anyways took it to the shop had ring replaced and went ahead and did a service plus sparkplugs and so on! Took it out this sunday and as soon as he started it he immediately notice somethings wrong! ?#@*?!!!!! anyways he let it idle a few minutes then tried it out and sure enough he was right it was weak! just paid almost $400.00 for the job we have a vacation coming up the week after the 4th and this sh*t happens! so we go back to the shop....where it seems they hate their job and finally have a mechanic look at it. he unbolts the hoses to the SC and sticks his finger in it and spins the charger! He says its not suppose to do that and now the supercharger is blown! need to replace it with a new one! which brings me to my other issue...they just replaced the SC about 8 months ago right before the warranty was up! so my question is what would be my least expensive route to get this thing up and going! The shop is suppose to call me tommorrow and give me a price!.. can't wait to see that bill??? but if it's to high that ski will probably have to sit there for a while cause they just moved in to a new place and some of you know how pricey that can be!! but any help and direction will be gladly appreciated!!


  2. #2
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Quote Originally Posted by Hector_750 View Post
    Well not sure where to start, but about 2 weeks ago a friend had some stuff caught up between the prop and the wear ring! cleaned it out and took the ski for a ride not suprisingly i had no holeshot power no topend so we figure it was the ring..this is the 3rd ring we replaced since we owned the ski or better yet since he owned it! its a 05' rxp!...anyways took it to the shop had ring replaced and went ahead and did a service plus sparkplugs and so on! Took it out this sunday and as soon as he started it he immediately notice somethings wrong! ?#@*?!!!!! anyways he let it idle a few minutes then tried it out and sure enough he was right it was weak! just paid almost $400.00 for the job we have a vacation coming up the week after the 4th and this sh*t happens! so we go back to the shop....where it seems they hate their job and finally have a mechanic look at it. he unbolts the hoses to the SC and sticks his finger in it and spins the charger! He says its not suppose to do that and now the supercharger is blown! need to replace it with a new one! which brings me to my other issue...they just replaced the SC about 8 months ago right before the warranty was up! so my question is what would be my least expensive route to get this thing up and going! The shop is suppose to call me tommorrow and give me a price!.. can't wait to see that bill??? but if it's to high that ski will probably have to sit there for a while cause they just moved in to a new place and some of you know how pricey that can be!! but any help and direction will be gladly appreciated!!
    It sure sounds like they replaced the SC with one with ceramic washers. If you lost those, the engine needs to come out and the oil pumps (at the least) need to be cleaned and/or replaced. My guess would be $2-k minimum. If you're lucky, maybe they put metal washers in and the SC is just slipping, which would just be an SC rebuild... Ron

  3. #3
    jpeconsult's Avatar
    Join Date
    Jul 2007
    Location
    Pineville, LA
    Posts
    5,448
    +1
    1
    Pull the SC and make sure all the parts are still in tact. If ANYTHING looks broken, chipped, etc...lean towards the $2,000. If everything looks fine, then buy the metal washers from Jerry and install as instructed. You can have those washers in a day or two. He is quick.

  4. #4
    Could it be slipping without the washers being damaged???

  5. #5

  6. #6
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Quote Originally Posted by Hector_750 View Post
    Could it be slipping without the washers being damaged???
    Like jpeconsult said, pull the SC and check to see if the ceramic washers are still intact... Ron

  7. #7
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2
    Quote Originally Posted by Hector_750 View Post
    Could it be slipping without the washers being damaged???
    Yes, but you would be very lucky if this is the case. Like everyone else has said, the only way to tell is to pull the SC to see if the washers are there.

  8. #8
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    99% of the time, if it spins freely with your finger, it's broken apart, not just worn

  9. #9
    jpeconsult's Avatar
    Join Date
    Jul 2007
    Location
    Pineville, LA
    Posts
    5,448
    +1
    1
    The SC can slip even with the washers intact. As I understand it, the harder you run the ski (example: from idle to WOT) You put the most force oin the SC parts, causing them to wear. Jerry sells shims in his store, that are two dollars for a pair...which I think everyone should have a spare set.

    Pull the SC, and if everything looks OK, send it to Jerry. You should have it back within a couple days...a week anyway.

  10. #10
    Well there is some good news the mechanic at the dealer told me he had an extra SC and would look out for me. He installed the new SC today and when I picked it up, He told me my bill was at the service dept. so I went and to my suprise $150.00 I asked him if the washers on the old one had broke or if there were any broken pieces that might have gone in to the pump or engine, but he claims no! So I will test this thing tommorrow and see how it runs. if it runs good then I'm going to pull it and send it to jerry to install the new washers!...Also off subject..anyone know what kind of RPM you get out of the 05' RXP and howabout the 08' RXP-X??

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Blown SC and maybe cracked block? Please HELP!
    By Tmlp103 in forum 4-Tec Performance
    Replies: 45
    Last Post: 03-27-2015, 12:54 AM
  2. how to fit solas any help please
    By rior1 in forum 4-Tec Performance
    Replies: 10
    Last Post: 02-07-2007, 04:40 PM
  3. Jerry Do You Need Any Help?
    By 1 FAST VE in forum Mudbug Nationals PWC.Life Rally
    Replies: 7
    Last Post: 01-22-2007, 01:54 PM
  4. motor filled with coolent..any help please....
    By tris in forum 4-Tec Performance
    Replies: 14
    Last Post: 10-04-2006, 06:56 PM
  5. 2nd blown SC..bov
    By mxl16 in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-31-2005, 06:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •