Results 1 to 5 of 5
  1. #1
    CARLRRE's Avatar
    Join Date
    May 2005
    Location
    VIRGINIA
    Posts
    146
    +1
    3

    Getting trim to work on a SL780

    I have a friend with an SL780 ski with the trim stuck in the full down position. In this position the ski just porpouses all the time. What is involved with at least moving the trim bucket up? The trim motor doesn't work... I want to be able to reset the bucket to at least the neutral position. Is this even possible? Is the trim motor protected by a fuse somewhere?? And if so, where would the fuse be located?? I haven't had a chance to really look at the ski.. Any help will be appreciated...I am hoping to be able to work on it this coming weekend... 4th of July holiday weekend..


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    More than likely the motor is rusted. Often it can be removed, cleaned up and will work fine again. I'd try that before you mess with "adjusting" it.

    No fuse for trim motor.

    Remove the trim motor from ski. Remove plastic cover. Carefully open the gear box noting proper gear position. Unscrew motor from gear box and use a pair of pliars to "free up" the motor. Test it with a 12V battery. If it works, re-install it. Regrease the gars and re-assemble. Reinstall and enjoy.

  3. #3
    CARLRRE's Avatar
    Join Date
    May 2005
    Location
    VIRGINIA
    Posts
    146
    +1
    3
    Xlint89, thank you for that information... I appreciate your taking the time to reply... Hopefully I can get it working for my friend this weekend... Thanks again... And thanks to Green Hulk for supplying this forum....

  4. #4
    RiverRat19405, im a rat in the water RiverRat19405's Avatar
    Join Date
    Apr 2007
    Location
    bridgeport pa
    Posts
    261
    if you cant get it off or working just disconnectthe trim rod for now an it will help

  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Quote Originally Posted by RiverRat19405 View Post
    if you cant get it off or working just disconnectthe trim rod for now an it will help
    And do what with the trim nozzle? Just let it bounce up and down?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help getting software to work on new CMD
    By hotbird in forum 4-Tec Performance
    Replies: 15
    Last Post: 05-06-2013, 07:41 PM
  2. Time to work on the bottom of the ski
    By mrbtd in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 06-15-2007, 09:03 AM
  3. Lets get down to it On Honda's
    By Dr Len in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 04-26-2007, 11:08 PM
  4. Sure is a lot easier to work on....
    By water worx in forum Polaris Open Discussion
    Replies: 8
    Last Post: 12-09-2006, 03:30 PM
  5. So a Lady brings me her skis to work on.....
    By QuickMick in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 05-29-2006, 09:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •