Results 1 to 5 of 5
  1. #1

    How do I test & clean Powervalves

    I installed WaveEaterclips last weekend and I cleaned out the inside of the PV case that I removed (pretty gunked up), but I did not attempt to clean the PV itself. Can I spray somthing on the PV to clean them up a bit?

    And how exactly to I test the PVs to make sure they are working correctly?? I read about a test by turn on ski then turn off and listen for them to cycle? Should I hear all 3 do somthing? Or should I see movement in the couplers?

    Its a 2000 1200XLL.

    Thanks...as always!


  2. #2
    I am getting about 50-53 mph top speed (dplate, WaveEater couplers and clips and pump kit). Would this be possible without the PowerValves working on a 2000 1200XLL?

  3. #3
    If your not doing something, its hard to screw up. stlouisramsfan's Avatar
    Join Date
    Jul 2007
    Location
    Pontoon Beach Illinois
    Posts
    1,115
    To see if your valves are cycling, do like you said and watch the couplings to make sure both the coupling and the shafts move in unison... on cleaning the powervalves, do not spray anything in there... just use a popcycle stick and some shop rags and wipe as much yamagoop out as you can.... need to get a d-plate in there so you can switch to synthetic oil....
    Last edited by stlouisramsfan; 07-01-2008 at 05:33 PM.

  4. #4
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    Quote Originally Posted by stlouisramsfan View Post
    To see if your valves are cycling, do like you said and watch the couplings to make sure both the coupling and the shafts move in unison... on cleaning the powervalves, do not spray anything in there... just use a popcycle stick and some shop rags and wipe as much yamagoop out as you can.... need to get a d-plate in there so you can switch to synthetic oil....
    +1

    Also, check your PV electrical connectors and make sure they are clean.

    If the PV motor does not cycle, here is a test to make sure the motor is good.


  5. #5
    Quote Originally Posted by stlouisramsfan View Post
    To see if your valves are cycling, do like you said and watch the couplings to make sure both the coupling and the shafts move in unison... on cleaning the powervalves, do not spray anything in there... just use a popcycle stick and some shop rags and wipe as much yamagoop out as you can.... need to get a d-plate in there so you can switch to synthetic oil....
    I just put a D Plate in 2 weeks ago. When switching to synthetic, do I need to drain out all of the yamaglue or can I just add the synthetic to the existing oil?? Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. help how do i test a cdi
    By big richard in forum Polaris How To & FAQs
    Replies: 0
    Last Post: 08-19-2008, 11:22 PM
  2. how do i test my batterie??
    By daverxp4 in forum 4-Tec Performance
    Replies: 24
    Last Post: 02-17-2008, 10:08 PM
  3. How do you test a oil pump
    By MNAPR in forum Yamaha How To & FAQs
    Replies: 10
    Last Post: 02-15-2008, 07:17 AM
  4. How Do I Test A Stop/go Switch??
    By BARLOWSRUN in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 11-03-2007, 08:34 PM
  5. How do you test a fuel guage/sender?
    By mystahagy in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 08-05-2007, 09:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •