Results 1 to 6 of 6
  1. #1

    2008 STX-15F wiring harness

    A little tip for everyone.
    We were getting intermittent error codes with a 2008 STX-15F. The DOS (vehicle down sensor) was sending alarms every five minutes.

    Two sensors later, it was clear it's not a sensor issue. So we checked with a different ECU.

    Worked for a day, and then the same problem occurred.

    So we replaced the whole wiring harness with one from a 2006 machine. The harnesses are different. The new one comes as a single unit, while the previous years come as two separate harnesses. It has worked for a few days since, so now it's wait and see, but I definitely think it's a wiring issue.

    Also, the connectors on the 2008 wiring come stuffed with grease, while the previous years they came with some clear dielectric coat, probably sprayed.

    So I guess this price cut from $9400 to $8200 had to come from somewhere.


  2. #2
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,994
    +1
    455
    Quote Originally Posted by goblin View Post
    A little tip for everyone.
    We were getting intermittent error codes with a 2008 STX-15F. The DOS (vehicle down sensor) was sending alarms every five minutes.

    Two sensors later, it was clear it's not a sensor issue. So we checked with a different ECU.

    Worked for a day, and then the same problem occurred.

    So we replaced the whole wiring harness with one from a 2006 machine. The harnesses are different. The new one comes as a single unit, while the previous years come as two separate harnesses. It has worked for a few days since, so now it's wait and see, but I definitely think it's a wiring issue.

    Also, the connectors on the 2008 wiring come stuffed with grease, while the previous years they came with some clear dielectric coat, probably sprayed.

    So I guess this price cut from $9400 to $8200 had to come from somewhere.
    Good info.. Keep us posted..

  3. #3
    So far so good. I just checked the price of the harnesses - the 2008 is around $350 in the US, which is more than twice less expensive than the previous two harnesses. I guess it was three times less expensive to manufacture too Too bad they didn't build it right. Unfortunately, the 2005 15F's seem the best build so far. One would think they would be getting better each year, too bad it doesn't seem to be the case.

  4. #4
    I had water in one of the joint connectors on my 15F. No dielectric grease on anything from the factory. I'm now going to go through every connector with contact cleaner and dielectric grease. That caused a no fuel, no spark condition, and no codes.

  5. #5

    Important Update !!!

    IMPORTANT UPDATE !!!

    Our second 2008 ski was giving us a weird problem too - electrical discharges in the handlebars !

    I wouldn't hurt, but it was clearly tickling when you ride.
    Definitely electrical discharges in the rider's hands. This came with intermittent difficult starts and small electrical gremlins.

    Then today it stopped, and gave us a COIL code. Several verifications with known good coils later, the code was still there. Then we found what the problem was:

    - The part of the harness which goes close to the bracket which holds the fuel filter is unprotected, and rubs in said bracket. It's simply held with a zip-tie, definitely a sloppy job !!! This is the part of the harness which powers the coils and the DOS sensor.

    Then the insulation gets stripped from the rubbing, and the live wire contacts the bracket. Hence the discharges in the handlebar. The bracket had traces from sparks, it has been doing it for a while.

    We went to the other ski (the one on which we changed the harness earlier) and checked the discarded 2008 harness - BINGO !!! Same live wire, same spot !!!

    Given that this is located right next to the fuel filter, I consider this a major issue. Sparks next to the fuel system are not a good thing in my opinion.

    SPREAD THE WORD !!! We don't have access to official Kawasaki channels (there's no official Kawasaki presence in the country where the ski is located), Kawasaki officials, if you read this - address the issue before someone's ski catches fire !!!

  6. #6
    inchadeboca's Avatar
    Join Date
    Oct 2007
    Location
    miami
    Posts
    555
    +1
    2
    WTF !
    i agree not good = caboom !!!

    man good info. will check mine.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Stx 15f wiring harness question
    By funboy30189 in forum Kawasaki How To & FAQs
    Replies: 3
    Last Post: 03-17-2016, 10:14 PM
  2. Replacing 15f wiring harness
    By STXRacer192 in forum Kawasaki How To & FAQs
    Replies: 0
    Last Post: 04-27-2009, 03:40 PM
  3. Chip in my Hull: 2008 STX-15F
    By sixtydashone in forum Kawasaki How To & FAQs
    Replies: 33
    Last Post: 09-05-2008, 05:39 AM
  4. 2008 STX - 15F Seat Cover?
    By sixtydashone in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 07-30-2008, 07:42 PM
  5. Just bought a 2008 STX-15F, Service Schedule?
    By mav7 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 06-08-2008, 12:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •