Results 1 to 5 of 5
  1. #1
    Resident Jicky Jack Jeff C's Avatar
    Join Date
    May 2005
    Location
    Twin Cities, MN
    Posts
    1,153

    Guys I need your help on something

    I pulled my pump off to inspect it and it is full of water!

    I have the skat triple bearing mod..............

    Anybody who has one of these mods and can help me, I am all ears.

    I pulled everything apart and used brake cleaner and compressed air to dry everything out.

    Back-up, when I pulled the paddle bolt that holds on the impeller on, it was only finger tight!! I tightened that sucker down real good, at least I thought.

    Ok, here is my question. If you look down where the bolt goes, you can see two grooves where it looks like o-rings go. Looks to me as if there should be 3 o-rings on the shaft. (FRom the threads back) at the end of the threads, there is an o-ring (That one is accounted for). about a half inch back on the bolt there is another groove for an o-ring (That one is acocunted for). About another 3/4" there is another groove inside where the bolt goes, that one is NOT accounted for. I am not sure if there should be an oring there at all, but there is a groove, so there should be right?

    I did not pay that much attention to it when I put it together, so I am at a loss.

    Anyone have their skat modded pump out right now that could take a looksie for me?

    Or anyone that definately knows can you post or PM me your phone number so I can call you?

    I gotta find an o-ring if that one is missing


  2. #2
    Jeff: I have my pump back in the ski already, but I remember only seeing 2 o-rings. Are you talking about the ones for the billet tail cone?
    Was the oil milky?

    I didn`t have any water in mine with 12.4 hours on it. changed out the oil with Amsoils new marine synthetic gear oil. will do it again in another 15 hours. The oil was dark and still smelled good...

    Did you get anything caught between the prop and the shaft seal, that would be a good place to look for water intrusion, and if the 2 o-rings are in there proper grooves...PR...

    Don`t forget to give Glen Perry @ Skat a call with your concerns...
    Ther was NO sealant between tail cone and pump housing*

  3. #3
    Resident Jicky Jack Jeff C's Avatar
    Join Date
    May 2005
    Location
    Twin Cities, MN
    Posts
    1,153
    PR:

    I talked to Jerry just now and with my impeller bolt almost falling off!!, that would make it leak.

    The oil and water had seperated and when I pulled off the cone, water literally sprayed out! like I had compressed air in it.

    I guess I need to tighten the hell out of that paddle bolt. With no way to check the torque on that Jerry recommended that I reef the hell out of it and NOT use loctite.

    I dried everything out with brake cleaner and compressed air and I am going to now put it back together.

  4. #4

    Join Date
    Apr 2005
    Location
    Elysian Fields,Tx
    Posts
    358
    When you say paddle bolt I assume you are referring to the rear of the shaft itself. This has nothing to do with the leakage of the pump. This only tightens the impeller on the shaft.To check for leakage you should do a vacuum test on the pump after assembly.There is a cone made for this test. Since you have the billet aluminum cone you should be able to use that hole for the vacuum test.If you don't have a vacuum gauge your dealer should be able to do this test if not any airconditioner repair place can run it. If it won't hold a vacuum it will leak.I think others have had leak problems with the Skat-Trak triple bearing pumps.

  5. #5
    Resident Jicky Jack Jeff C's Avatar
    Join Date
    May 2005
    Location
    Twin Cities, MN
    Posts
    1,153
    Quote Originally Posted by Rocketman
    When you say paddle bolt I assume you are referring to the rear of the shaft itself. This has nothing to do with the leakage of the pump. This only tightens the impeller on the shaft.To check for leakage you should do a vacuum test on the pump after assembly.There is a cone made for this test. Since you have the billet aluminum cone you should be able to use that hole for the vacuum test.If you don't have a vacuum gauge your dealer should be able to do this test if not any airconditioner repair place can run it. If it won't hold a vacuum it will leak.I think others have had leak problems with the Skat-Trak triple bearing pumps.
    If the bolt is loose it would leak for sure past the o-ring closest to the threads. The bolt would have come off in no less than one additional hour of riding.

    I just reefed on the bolt as hard as I could. I do not have time for a leaktest before I go on my trip. I think all is well now.

    Thanks for the input, I appreciate it...........

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Guys - I need your help with my VXR...I can not remove this freakin intake grate!!
    By smokeonthewater in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 03-25-2012, 04:31 AM
  2. Need your help guys!
    By jhill19 in forum Open Discussion
    Replies: 7
    Last Post: 03-19-2012, 02:45 AM
  3. Any Honda Techs on here??? I need your help!!!
    By Dockside in forum Open Discussion
    Replies: 12
    Last Post: 02-08-2012, 12:47 PM
  4. Few more ?'s on my 93 xp ALMOST DONE!!! JUST NEED YOUR HELP!
    By Milano325i in forum 2-Stroke Performance
    Replies: 1
    Last Post: 05-07-2010, 05:26 AM
  5. Need your help guys
    By Mick in forum 4-Tec Performance
    Replies: 3
    Last Post: 02-25-2010, 08:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •