Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1
    Ahh....where am I?
    Join Date
    Jul 2006
    Location
    Baywood - Brick, NJ
    Posts
    312
    +1
    1

    MAINT Flashes on controls...

    MAINT is displayed on the info center when the key is installed, it then goes away.

    I hit set 5 times to see what code shows up... end is all I get.


  2. #2

    Join Date
    Jul 2005
    Location
    SE Texas
    Posts
    396
    +1
    3
    Greetings--

    Its your gentle reminder that a maintainance time period is up-- 10 hrs 50 hrs 100 hrs ect.

    Only a dealer can reset it.

  3. #3

    Join Date
    Aug 2005
    Location
    Salinas CA
    Posts
    451
    I don`t think the dealer only part of that is true. Mine came up for the 10 hour service, the S/C clutch took a dump. So while I was getting that corrected the batt. was put in storage and reinstalled later. No maint. warning flashes now. Try unhooking the batt. for the night and see what happens.

  4. #4
    Ahh....where am I?
    Join Date
    Jul 2006
    Location
    Baywood - Brick, NJ
    Posts
    312
    +1
    1
    I'll try that! I was thinking of taking the batt out anyway and giving it a good change.

  5. #5

    Join Date
    Aug 2005
    Location
    Salinas CA
    Posts
    451
    Quote Originally Posted by majundecid
    I'll try that! I was thinking of taking the batt out anyway and giving it a good change.
    It`s OK to charge the battery. Just don`t over charge it. If you cook it, you`ll reduce it`s life span.

  6. #6
    Will work on YOUR ski for FREE! GeoRXT's Avatar
    Join Date
    Mar 2006
    Location
    Miami, FL
    Posts
    4,438
    +1
    1
    This flashes on mine everytime. It has been at the dealer twice and still comes out with it...huh!

  7. #7
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    then he's not doing it properly GEO. he needs to reset the maintenance light and reset the maintenance timer clock on BUDS. then he needs to "WRITE" that data into the ski and it will not do it until the next reminder.

  8. #8
    Will work on YOUR ski for FREE! GeoRXT's Avatar
    Join Date
    Mar 2006
    Location
    Miami, FL
    Posts
    4,438
    +1
    1
    I am taking it to PPG next week to get the mats done and I will let them know what's going on. They should have taken care of it a few weeks ago when it was there. They took the liberty of fixing the front storage hood shock and the rear corner bumper without even asking me and they could not take care of that....?

  9. #9
    Ahh....where am I?
    Join Date
    Jul 2006
    Location
    Baywood - Brick, NJ
    Posts
    312
    +1
    1
    GEO, your front storage Gas Spring went too?

    Mine as well. 8 months after I brought it home. I should have it...well I should have been called already....But I should have it any day now.

  10. #10
    Will work on YOUR ski for FREE! GeoRXT's Avatar
    Join Date
    Mar 2006
    Location
    Miami, FL
    Posts
    4,438
    +1
    1
    Quote Originally Posted by majundecid
    GEO, your front storage Gas Spring went too?

    Mine as well. 8 months after I brought it home. I should have it...well I should have been called already....But I should have it any day now.
    Yup, I'd say at about the same time as you. I never asked for it to be replaced cuz I wanted to do it myself and avoid a $90 fee for installation, but Im glad they did it cuz it had been about 4 months of me saying I'll do it tomorrow!

    And what a pain in the ass was it to hold the hood with your head or neck huh!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MAINT and Light flashes on 02 GTX DI
    By bvoltchenko in forum 2-Stroke Performance
    Replies: 0
    Last Post: 08-07-2009, 01:38 PM
  2. question about the riva ecu MAINT flashes on start up.
    By aussie rxp in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-24-2008, 09:15 AM
  3. 04 RXP-MAINT flashes for 10 seconds on Start.
    By -=aLiEno4RXP=- in forum 4-Tec Performance
    Replies: 9
    Last Post: 08-16-2008, 12:14 AM
  4. 2004 RXP - "MAINT" flashes on Dashboard
    By premlulla in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 02-07-2007, 12:21 PM
  5. maint flashing on display
    By Krazy-K in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-08-2005, 09:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •