Results 1 to 4 of 4

Thread: VTS not working

  1. #1

    Join Date
    Jan 2008
    Location
    Canada
    Posts
    93

    VTS not working

    I have a 96 seadoo gsx 787. My VTS has never worked when i brought it. How do i know if it is the motor, the module or the wiring? When i press the button, i can hear the relay click. There are 3 wires vts plug going into the module or motor. Can someone tell me which wire is power and which wire is ground so i can put direct power and test it. I'm new to this seadoo thing. Hope someone can tell me how to check it. Thanx.


  2. #2
    PhilnEdee's Avatar
    Join Date
    Aug 2007
    Location
    Union Grove, Alabama
    Posts
    477

    without looking I'm not sure which wire is which, but I would bet the motor may be kind of jammed if its clicking...can you kind of "help" it go up and down while hitting the switch to see if it can be broken loose and maybe lubed?

  3. #3
    to check the dc motor all you have to do is take the cover off of the vts unit and you will see the motor in there with two wires and they are connected via quick connects. disconnect the wires and then make a wire to put on the leads then touch the leads to the pos and neg side of the battery, remember polarity does not really matter as all that happens is when it goes up the positive is on one lead and when it goes down the positive is switched to the other side. so you dont have to worry about shorting something out. all this will tell you is that the motor is working or not. if the motor is good then you module is bad and that sucks, i just burned up my second vts module on my 98 xpl. there is a guy in canada that repairs them with all new upgraded circuitry for 125.00. you can find his ad on www.canadianpwc.com.
    hope this helps

  4. #4
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    Quote Originally Posted by rxpx2008 View Post
    I have a 96 seadoo gsx 787. My VTS has never worked when i brought it. How do i know if it is the motor, the module or the wiring? When i press the button, i can hear the relay click. There are 3 wires vts plug going into the module or motor. Can someone tell me which wire is power and which wire is ground so i can put direct power and test it. I'm new to this seadoo thing. Hope someone can tell me how to check it. Thanx.
    check this link out
    http://www.sea-doo.net/techarticles/vts/index.html

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. VTS Not working help
    By CarFanatic in forum 4-Tec Performance
    Replies: 20
    Last Post: 07-02-2008, 09:26 PM
  2. RXTX VTS Not working
    By STSPERFORMANCE in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-27-2008, 11:01 AM
  3. Vts not working
    By eclipsecleaning in forum 4-Tec Performance
    Replies: 1
    Last Post: 09-10-2007, 07:32 AM
  4. VTS not working
    By North49 in forum 4-Tec Performance
    Replies: 19
    Last Post: 06-11-2007, 08:06 PM
  5. VTS Not Working
    By Tas_RXP in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 03-29-2006, 05:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •