Results 1 to 5 of 5
  1. #1
    ArmyRXP's Avatar
    Join Date
    Jul 2005
    Location
    Ft. Drum, NY
    Posts
    259

    Bad Cavitation!!! Need Help!!

    Like it says, off the line I'm all over the rev limiter and the tach is at 8150rpms adn bouncing off the limiter unless I let off a little then hit it while going about 5-10 mph then I am fine with a good hole shot. Check the wear ring, its brand new, no gouges in it. Moved my rubber boot over the drive shaft that holds the carbon ring towards the bow about a 1/4 in., no water in hull, nose cone is on the 15/20R. also due to heat fade I pull about 7950 rpms down from 8100 rpm in the spring with cooler weather but hey it is the summer. Not sure what else to check but need to do something the hole shot sucks!!

    All in all was cruzing at about 40-45 wife went by adn was racing a 04 RXP, he went past her and me then I hit it and walked him hard so I know she is running good on the top so just need some help with the cavitation.

    Gary

    Oh no porpising either when maxed out at 7something still need to GPS it.


  2. #2

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by ArmyRXP View Post
    Like it says, off the line I'm all over the rev limiter and the tach is at 8150rpms adn bouncing off the limiter unless I let off a little then hit it while going about 5-10 mph then I am fine with a good hole shot. Check the wear ring, its brand new, no gouges in it. Moved my rubber boot over the drive shaft that holds the carbon ring towards the bow about a 1/4 in., no water in hull, nose cone is on the 15/20R. also due to heat fade I pull about 7950 rpms down from 8100 rpm in the spring with cooler weather but hey it is the summer. Not sure what else to check but need to do something the hole shot sucks!!

    All in all was cruzing at about 40-45 wife went by adn was racing a 04 RXP, he went past her and me then I hit it and walked him hard so I know she is running good on the top so just need some help with the cavitation.

    Gary

    Oh no porpising either when maxed out at 7something still need to GPS it.
    put a new wear ring in, have you had it out to check?

  3. #3
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,559
    +1
    948
    im dealing with the same issue, people have said engine alignment is a big cause of it where the carbon ring will allow the pump to suck air, im guessing thats what my issue is because on top im over 80, but like you i am all over the rev limiter from 5 and below mph
    i gave up on it actually and decided to ride it out for the summer
    i magine thats what your problem is

  4. #4

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by seadoo02xp View Post
    im dealing with the same issue, people have said engine alignment is a big cause of it where the carbon ring will allow the pump to suck air, im guessing thats what my issue is because on top im over 80, but like you i am all over the rev limiter from 5 and below mph
    i gave up on it actually and decided to ride it out for the summer
    i magine thats what your problem is
    to eliminate it. put some cling film over the carbon ring, test it for 1 munite if your probs are still there, look further

  5. #5
    ArmyRXP's Avatar
    Join Date
    Jul 2005
    Location
    Ft. Drum, NY
    Posts
    259
    Will have to pull the pump on Friday and take a good look at the wear ring. Ever since I moved the rubber boot forward it did get rid of the cavitation for a day then it came back but before I did the boot trick there was alot of water in the hull which made me do that trick. Guess I will just ride it out this year then next year while deployed again will have the wife take it in and have the ring and boot replaced. I will tell you though man this Green Wheel and 15/20R (untouched) really rips I like seeing the Dreamo go to 75 then creep to 80 LOL... man I love it just need the Ext I/C and a Shorty WB.

    Gary

    Will keep you posted on what I find.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 06-14-2012, 06:44 PM
  2. Question on "Possible" bad deal, Need help. Concerning XS I/C
    By OrlandoRXP in forum 4-Tec Performance
    Replies: 68
    Last Post: 08-23-2009, 09:26 PM
  3. cavitation need help!
    By cliff717 in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-02-2009, 10:42 PM
  4. SL 750 Possible Bad Piston...Need help...
    By bigbadb in forum Polaris How To & FAQs
    Replies: 14
    Last Post: 02-11-2009, 09:00 AM
  5. new SS and cavitation...need help!
    By pet in forum 4-Tec Performance
    Replies: 44
    Last Post: 06-17-2007, 09:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •