Results 1 to 5 of 5
  1. #1
    just GOT TO DO IT! great lakes gpr 1200's Avatar
    Join Date
    May 2006
    Location
    muskegon michigan
    Posts
    798

    help needed with old spx ski

    I got this e-mail today from a freind: " We took the jet ski out last weekend. It was running great and when I was in the middle of the river the throttle stopped working and the jet ski slowed down to idle. I could not give it any gas. It was almost like the throttle was completely loose. It also wouldn't turn back on. I got a tow back to our dock. We checked everything and the spark plugs. It then turned on sounding completely normal. It looked fine so we took it out again and after 2 minutes of it running fine it did the same thing again. Do you know what might be the problem with it?"

    He is german so the english is subject to interpatation (so is mine and I was born here! )... Can any one make heads or tails of it? Please help. sounds to me like it is running out of fuel after a short time of running? but why with this model?


  2. #2
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    Sounds like its leaning out and running out of fuel. Do a compression test first to see if you have good PSI still in each cylinder. If good, its time to clean the screens! Complete carb rebuild, clean the little screens in the carbs,change the fuel lines, clean the fuel selector, and the filter screen in the front. Thats the best i can give you with out more history on the ski. Lucky he didnt smoke the motor.

  3. #3
    just GOT TO DO IT! great lakes gpr 1200's Avatar
    Join Date
    May 2006
    Location
    muskegon michigan
    Posts
    798
    Yes I just wanted to narrow it down. I think It is a fuel pump diaphram? or maybe selector? I have seen the little filters go bad and that is so close (in the fuel system to the cly) that the ski is doggy on top end but idles fine. I just didn't want to go threw the hole system ya know?

  4. #4
    PEST!'s Avatar
    Join Date
    Jun 2008
    Location
    Rockledge Florida
    Posts
    768
    why not the tank vent ? loosen the cap when this happens and see if it will run.

  5. #5
    steach's Avatar
    Join Date
    Dec 2005
    Location
    Rock Tavern, NY
    Posts
    3,174
    +1
    174
    Check the pivot pins in the throttle lever. Because of the design, the cable keeps it in place (looks normal) but when you press it it colapses on the bars.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help needed with educational materials
    By shawn alladio in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 12-29-2007, 02:47 PM
  2. some help needed with cam timing
    By Bastiaan maarten Bok in forum 4-Tec Performance
    Replies: 4
    Last Post: 11-11-2007, 06:02 PM
  3. I need some help. Need to get a ski back from Havasu
    By skywalker in forum Open Discussion
    Replies: 4
    Last Post: 09-20-2007, 09:17 PM
  4. help needed with old gtx
    By great lakes gpr 1200 in forum 2-Stroke Performance
    Replies: 5
    Last Post: 06-15-2007, 08:07 PM
  5. Help needed with propane grill
    By way2fast in forum Open Discussion
    Replies: 18
    Last Post: 03-04-2007, 03:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •