Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Help Please I think maybe sucked up something

    I am on my cousins comp. GYTWYPT here.

    I am not sure what happend. 3 of us rode about 21 miles by the honda speedo. I turned my 06 RXP off after averaging around 60 the whole way. I started it back up to cruise into a loading ramp and at idle it is fine, but when I give it gas it vibrates bad and feels like it is cavitating but maybe a little more violant than that. I reached under and found a couple very small twigs wedged in the cracks of the new Riva grate that shibby sent down here.
    I remember reading a similar thread about this but I can not find it now.
    I have a couple more days of riding so I am hoping someone can help me out with this.

    Thanks again guys
    Joe


  2. #2
    wolf513's Avatar
    Join Date
    Jun 2008
    Location
    Sacramento, CA
    Posts
    92
    I agree it sounds like something was sucked up. Try removing the grate and/or pump and cleaning out all the twigs and garbage that you find in there.

  3. #3
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,567
    +1
    4,784
    Yeah happens to a lot of us from time to time, put it on the trailer, get a flashlight and crawl under the grate, inspect it very carefully, even a tiny stick or chip of wood can create the problem you are describing. Once that is removed it should be fine. If you can't get to it then you will need to remove the grate and get it out, this is pretty common.

  4. #4
    JOEYD0730's Avatar
    Join Date
    Jun 2008
    Location
    queens, ny
    Posts
    49
    +1
    1
    a twig is prob stuck between the wear ring and prop. had this happen when i picked up a plastic nut, got wedged in here.

  5. #5
    I was kinda thinking that was the answer I was going to get. Ski is on its way back had to leave it along with my cousins yamaha that the starter went out on. His wife went and picked him and the two skis up. Not real good luck today.
    If that is the case how in the heck does a twig stay in there and not get chewed up and spit out? I remember reading on the thread that I saw earlier that something like a cigarett butt could cause this. Wierd.

    Thanks I will be looking in there as soon as it gets back and let you all know what I see.

  6. #6
    Well there was nothing between the prop and wear ring but there was a piece of wood stuck on the intake side of one of the prop blades. A little bigger than a cigarete butt. It chopped about half way through it. Hopefully it is as easy as that. Will find out tomorrow.
    Thanks again everyone
    Joe

  7. #7
    cbrich's Avatar
    Join Date
    Nov 2006
    Location
    Around Lake Travis
    Posts
    1,374
    +1
    1
    I would not mess with removing the intake grate, just pull the pump and be done with it. Pulling the pump only requires a 17mm deep socket, 12" extension, ratchet, and two 10mm wrenches. I sucked up my dock and only took 5 minutes to remove the pump.

  8. #8
    Didnt have to remove anything. My cousin reached up in the intake grate with a little pry bar and just plucked it off the prop.

  9. #9
    outboard john's Avatar
    Join Date
    Jun 2006
    Location
    Escondido, Ca.
    Posts
    474
    +1
    2
    Quote Originally Posted by cbrich View Post
    I would not mess with removing the intake grate, just pull the pump and be done with it. Pulling the pump only requires a 17mm deep socket, 12" extension, ratchet, and two 10mm wrenches. I sucked up my dock and only took 5 minutes to remove the pump.

    Wow Rich, You sucked up a dock and then were able to remove it in only 5 minutes Most impressive

    OBJ

  10. #10

    Join Date
    Mar 2008
    Location
    Harrisonville Missouri
    Posts
    239
    Well I made it back home. I was able to put about 10 hrs on the ski during my vacation. Thanks for the help with the problem. Hard to believe that the little piece of wood stuck to the prop could cause such caos. Even harder for me to belive that it could stay on there.

    Thanks again
    Joe

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I think I sucked up some leaves, please help.
    By Fink in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 07-03-2013, 05:19 PM
  2. Sucked Up Wakeboard Rope---Please Help
    By VXRBlue in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 07-21-2012, 03:30 PM
  3. Sea Doo Sucked Up Rope....Please Help!!
    By wingsfedorov in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-12-2008, 12:53 AM
  4. Somethings wrong with my machine, help, please read!!!
    By NeverEndn in forum 4-Tec Performance
    Replies: 15
    Last Post: 08-11-2006, 09:57 AM
  5. Sucked up rocks!!!!! Help me with the damage!
    By TorquePhoto in forum 4-Tec Performance
    Replies: 16
    Last Post: 08-01-2006, 03:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •