Page 1 of 2 12 LastLast
Results 1 to 10 of 20
  1. #1

    1999 GTXL 951 no spark :(

    I've got a 99' GTXL and I'm not getting any spark. I bought it as a basket case and rebuilt the engine. Cleaned all connections, checked ac output of trigger coil, was ok plus tach reads 500 rpm when cranking with no plugs in. Checked coil wires (white ones) to MPEM and got good continuity. Cleaned coils and clipped plug wires back, wires read about 1 ohm. Coils check about 15k ohms secondary and .5-.7 ohms primary side. MPEM is not popping fuses but the someone previously put a 7.5 amp in place of the 5 amp fuse. Looks like I need a new (used) MPEM???? Any help would be greatly appreciated, going on vacation next weekend!

  2. #2
    96XPSS's Avatar
    Join Date
    Feb 2006
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Did you remember to hook up the grounds to the engine?

    When rebuilding...did you verify the inductive pickup was intact and attached to the front cover?

  3. #3
    Yup, hooked the grounds up to the engine on the front cover where there's a little ear sticking out on the starter side. Ran a jumper from the grounds to the batt. negative as well just to make sure. Pickup is intact and attached.
    I pulled the cover off again and checked the resistance on it, was getting somewhere around 300 ohms, can't remember the exact number, but it was in spec according to my manual. I was also getting about .35 volts AC out of it while cranking the engine (manual said .25-.5 volts or something like that). I made some jumper wires from some AMP female pins and wire. I unplugged the engine plug and put them on the pickup pins and recorded that voltage while cranking. Also got same voltage by back-probing the wires up on the MPEM while cranking. I'm guessing the tach wouldn't read 500rpm while cranking if the pickup wasn't working?
    One of the bolts on the MPEM is loose, which makes me wonder a bit, as well as having the wrong fuse..... I got the ski with one cyl with a bunch of water in it and assumed that was the reason it wasn't running and rebuilt the engine. Maybe the MPEM died and someone let it sit for a while with the plug out or water ran in from the exhaust while it was parked for god knows how long?

  4. #4
    water worx's Avatar
    Join Date
    Aug 2006
    Sunny Fla,Ft Pierce
    I have a good used one for a 99 GTXL,new is over $800,I want $350 plus shipping & it comes with dess key. LMK cause I was gonna put it on ebay.

  5. #5

    Angry Stupid ignition......

    Bought a know good MPEM from Waterworx (Dan) and installed it today, hit all the connections on the MPEM, engine plug, and Connections and plugs in the rear electrical box with contact cleaner again. Still no damn spark! Trigger coil reads 250 ohms, right in middle of spec. Manual I have says I should get .35-.6 volts ac out of it while cranking the engine. I'm only getting between .12 and .16 but maybe that could be chalked up to different meters? I'm thinking the trigger coil is the next thing to throw at it.... Any ideas? Ignition coils are reading .5 ohms primary side and 15k ohms with the caps and wires on the secondary side. I put the positive lead of my meter on the white primary wire at the coil, while its disconnected from the coil and ground the black lead and I get -3 to -4 volts DC and it drops to -2 while cranking? I disconnect battery and the volts stay the same, but I'm chalking that up to a capacitor in the MPEM.
    I'm wanting to hit it with a big hammer but from past experience many years ago, I'm not

  6. #6
    96XPSS's Avatar
    Join Date
    Feb 2006
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Wow...what a pain!

    Check your pins on the front cover of your engine.

  7. #7
    PEST!'s Avatar
    Join Date
    Jun 2008
    Rockledge Florida
    Check all the pins. The pins inside the mpem plugs can push out and also can corode and not make a good conection also plugs on the engine. I had one I fixed for another tech that had one pin in the front engine plug that would push back when plugged in and make a connection some times and not others. drove him nuts.

  8. #8
    This is what I found with the coil in the 99 service manual. Typically if the primary windings are higher than spec the coil is toast. It's saying the max allowable limit is 0.46 Ohms of resistance on the primary. A little thought though, if the engine was rebuilt, did they change out the plug caps to the hard plastic NGK caps with built in resistors? If so they are a nightmare and a huge mistake on NKG's part. Those internal cap resistors always die. Just a thought. Also, is it possible that the issue isn't a bad ground rather a short to ground somewhere?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	99 GTXL.JPG 
Views:	167 
Size:	207.2 KB 
ID:	82854  

  9. #9
    Thanks guys, I'll double check the 6 pin connector tomorrow. The ohm readings i was getting were from a clymer manual I have, probably not as good as the factory book. I did the rebuild on it and it has the rubber plug caps, not the hard plastic ones that crack all the time
    New trigger coil should be in in a couple of days. I've been cranking it with no pipe on it, because the pipe gets in the way of EVERYTHING when working on it, my first 951.... It's quite a sight, fan blowing into the hull to keep it vented and me cranking it with ear protection on. The neighbors are gonna love it when it fires up! They might be used to it by now though..... I fixed a 97' GTX a few weeks ago and shot a little starting fluid in it, just to see if it was gonna run. Coil connection were a little corroded and it got a mis-timed spark and back-fired out the exhaust so hard that it blew one of the rubber connectors off and filled the hull with smoke. No fire, so I guess it's ok, but my ears were ringing for a few hours... Put connector back on good and tight Hit it again.... Backfire #2 and this one shatters the plastic thru-hull exhaust fitting into about 10 pieces! And fills the hull with so much smole i can't see the engine! People come running to find out what the explosion was..... After cleaning the dirty coil connections, it fired right up and runs fine.... I love working on skis.....

  10. #10
    Ok, changed MPEM with one from water worx. Bought new trigger coil and installed. Still no spark. Fuses are all good. Display shows 500RPM while cranking engine. Coils both test good for ohms, tested coils by scratching a battery charger across the primary terminal while the neg was hooked to the coil frame and got a spark from both plug wires. I get a reading of -3 volts that moves about .3 volts +-. Doesn't seem to really change while cranking. Shouldn't I be getting battery voltage to the primary side of the coils when the ignition is "on" (white wires)? I bought it as a basket case and I might be missing a ground? I have the one from the coil box, where the plug boots can go and one other from the harness that runs from the MPEM to the rear electrical box. I hooked both of these to the extra bolt on the front engine cover to ground them. Negative battery terminal is attached to one of the starter bolts. Am I missing anything? This thing is driving me nuts..... Thanks, Rob D.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 1999 GTXL Craig Warners Ocean Surf Closed course boat
    By WICKEDSEADOO in forum Sea Doo 2 Stroke Skis
    Replies: 27
    Last Post: 03-30-2012, 03:12 AM
  2. 1999 XPL - 951 CC Engine - Repair or Replace?
    By lbijeep in forum 2-Stroke Performance
    Replies: 10
    Last Post: 05-29-2010, 10:50 AM
  3. WTB Need a drive shaft for a 98 - 99 GTXL 951
    By onefastgpr619 in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 04-25-2010, 08:04 PM
  4. 1999 1050 SLTX, no spark on MAG Cylinder
    By dragpro in forum Polaris Open Discussion
    Replies: 7
    Last Post: 08-15-2008, 12:31 AM
  5. i am buying a seadoo gtx 1999 with 951 engine is this a dependable ski?
    By troyg1130 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 10-21-2007, 10:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts