Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    Student of Speed rxpwhistler1's Avatar
    Join Date
    Nov 2007
    Location
    Oakland County Michigan
    Posts
    708

    Someone help! Save the 2004 RXP!!!

    I was out on the water a while back and the oil light kept coming on. I had just recently performed an oil change and knew it had plenty of oil and the dipstick did not reflect overfill-so I kept riding. I let a friend (i know i know) take it out and noticed him sitting still after ten minutes. We took the boat up to him and he said it wouldn't start. I opened up the engine compartment and saw the oil fill cap had unscrewed itself somehow from too much pressure. I closed it and started it...took about 5 minutes to start. Once it started it had a knock, only to be heard when the seat is off.

    I performed a compression test (without it hot as I do not want to start it..) and all three cylinders were the same. I thought maybe a rod through a lifter or something along those lines, but wouldn't that show bad compression in a cylinder???

    Seems that it ran ok after that happened on the way back to the dock, but it knocks.

    Can anyone please tell me what I should check or do before I pull the head to inspect? Also a plug or two seem to reflect lean running on the bottom of the plug, not sure if that helps.

    Thanks guys


  2. #2
    Student of Speed rxpwhistler1's Avatar
    Join Date
    Nov 2007
    Location
    Oakland County Michigan
    Posts
    708

    ?

    25 views and nobody can throw a little help out?

  3. #3
    bigdeez's Avatar
    Join Date
    Jul 2006
    Location
    jax
    Posts
    218
    you might have spun a bearing? did all the oil pump out through the cap?

  4. #4
    RidE till i GeT WeT
    Join Date
    Jun 2008
    Location
    Atlanta,Ga
    Posts
    24
    Yo i have a 04 rxp and mine is doin the same thing about the Oil light and it has oil and has a lil knocking.. The RPMs are jumping but the ski isn`t goin.. so i am lost.....

  5. #5
    The most interesting man in the world. Nils888's Avatar
    Join Date
    Jun 2005
    Location
    California
    Posts
    4,231
    +1
    1,043
    Pull the oil filter out and look for copper colored metal.

  6. #6
    Student of Speed rxpwhistler1's Avatar
    Join Date
    Nov 2007
    Location
    Oakland County Michigan
    Posts
    708

    ut oh

    I just pulled the oil filter and there are small amounts of tiny bits of copper and under the filter there was a metal goo!

    What does this mean exactly? Thanks nils or anybody else who can help me

  7. #7

    Join Date
    Feb 2006
    Location
    Birmingham AL
    Posts
    2,924
    +1
    2
    bearing material that motor is shot time for a rebuild or a new motor.

  8. #8
    Student of Speed rxpwhistler1's Avatar
    Join Date
    Nov 2007
    Location
    Oakland County Michigan
    Posts
    708

    ??

    Quote Originally Posted by Lvnspeed View Post
    bearing material that motor is shot time for a rebuild or a new motor.
    I don't see how running it for 5 mins on low oil could destroy the entire motor?!

  9. #9
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    Quote Originally Posted by rxpwhistler1 View Post
    I don't see how running it for 5 mins on low oil could destroy the entire motor?!
    uhm.....depending on how low it was, ....which it sounds like it was very low, well the engine basically got starved of lubrication. So friction was the result of the bearing material being excessively worn. It does not take long to wipe out a bearing(s). Remember, when the engine is running, you can have anywhere from 1/2 quart to 1 quart of oil in all the oil galleys and top end. So, if your level was very very low, the pump got starved and the bearings lost lubrication. Lubrication is needed to prevent the surfaces of the cranks and bearing from touching each other [metal to metal]...friction

    that motor got oil starved basically.....5 minutes is a VERY LONG time with no oil lubrication
    Last edited by RX951; 07-13-2008 at 10:40 AM.

  10. #10
    Quote Originally Posted by rxpwhistler1 View Post
    I don't see how running it for 5 mins on low oil could destroy the entire motor?!
    It only takes a few seconds to destroy the bearings running low on oil.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help determining if 2004 rxp has blown head gasket
    By davehekhuis in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 09-11-2013, 11:00 PM
  2. Is the 2004 RXP aftermarket water box worth buying
    By Dragdaddy71 in forum 4-Tec Performance
    Replies: 4
    Last Post: 03-11-2013, 12:37 AM
  3. Need help with my 2004 rxp
    By ddlawnguy in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-18-2011, 07:05 PM
  4. Help save the bus driver!
    By airbornexp in forum Open Discussion
    Replies: 24
    Last Post: 12-16-2010, 02:47 PM
  5. LOST my RXP manual on the computer can someone help?
    By Water4fire in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 01-21-2006, 10:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •