Results 1 to 3 of 3
  1. #1
    mstennes's Avatar
    Join Date
    Jul 2006
    Location
    On the Columbia River above a Dam
    Posts
    843
    +1
    1

    Riva ECU and a Rude SC = stumble, WTF???

    I just installed my Riva ECU, 50# injectors, Shorty H2Obox, Riva vavle train , etc, etc, anyway when I first punch it it has a bog, it also does it if your going and let off, let the R's fall than nail it again, what have I missed or done wrong???? My tech also read in the programming sheet where it needs a programming update CD, is that needed? It programmed up fine (I think), thanks!

    On a side note my Rude was used and had a couple issues so I hjad a 08 SC overhaul kit which was installed could this be the problem, using stock BRP washers and overhaul kit?
    Last edited by mstennes; 07-12-2008 at 08:28 AM.


  2. #2
    The most interesting man in the world. Nils888's Avatar
    Join Date
    Jun 2005
    Location
    California
    Posts
    4,230
    +1
    1,043
    Did your tech reset the trottle position in the buds software????

    The brp washers should be fine. just remember to recheck the slip on the clutch after 10 hours!

  3. #3
    mstennes's Avatar
    Join Date
    Jul 2006
    Location
    On the Columbia River above a Dam
    Posts
    843
    +1
    1
    I dont know I will have to ask him??? To clairify its more of a bog than stumble it just falls flat until it builds some R's I will ask him if he reset the TB sensor.
    Thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Riva ecu and mini rude
    By monaroman76 in forum 4-Tec Performance
    Replies: 6
    Last Post: 11-20-2011, 05:18 AM
  2. Riva ECU and mini rude upgrade will need RRFPR?
    By Lbaronio in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-11-2010, 02:30 PM
  3. WTB Riva Ecu and 50 lbs injectors
    By edvazquez in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 09-19-2008, 07:13 AM
  4. wtb 2004 rxp riva ecu and 50lb injectors
    By Extrememotors in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 05-04-2008, 07:19 PM
  5. Riva ECU and NEW C-kit. DO I need a FPR?
    By Water4fire in forum 4-Tec Performance
    Replies: 18
    Last Post: 12-18-2007, 01:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •