Results 1 to 9 of 9
  1. #1
    dsmcrazy79's Avatar
    Join Date
    May 2008
    Location
    GURNEE, IL AREA
    Posts
    17

    Need Help Installing Rrfpr!!!

    Hi Guys,

    I just picked up a new "X" charger and a Rude RRFPR......maybe I'm just blind but where does the RRFPR bolt to?

    Please help, thanks guys...

    Martin.


  2. #2
    dsmcrazy79's Avatar
    Join Date
    May 2008
    Location
    GURNEE, IL AREA
    Posts
    17
    ok, guys...never mind....I got the fuel regulator mounted but wondering where you guys tapped into for the vacuum....

    What's the best location to tap for the vacuum fitting....thanks guys....

  3. #3
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    If your running a Aftermarket IC you can tap into the IC block off on the end of the intake manifold..If not tap into one of the plastic runners on the top of the intake manifold....

  4. #4
    dsmcrazy79's Avatar
    Join Date
    May 2008
    Location
    GURNEE, IL AREA
    Posts
    17
    Thank you Snoman....that helps a lot....

    Martin.

  5. #5
    dsmcrazy79's Avatar
    Join Date
    May 2008
    Location
    GURNEE, IL AREA
    Posts
    17
    One more question....I just started the jet ski and the rpm at idle is kind of high....it's running at 3200 rpm...

    By the way, this is a 2005 rxt with a "X" charger and a Rude RRFPR...

    Have you guys had issues like this, any help is appreciated...

  6. #6
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    What size injectors are you running???Also where did you set your regulator to???

  7. #7
    dsmcrazy79's Avatar
    Join Date
    May 2008
    Location
    GURNEE, IL AREA
    Posts
    17
    Quote Originally Posted by Snoman View Post
    What size injectors are you running???Also where did you set your regulator to???
    Stock injectors, and 60psi for the regulator..

  8. #8
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    No vacum leaks??The regulator is all the way down...All lines are tight...

  9. #9
    dsmcrazy79's Avatar
    Join Date
    May 2008
    Location
    GURNEE, IL AREA
    Posts
    17
    Ok, everything is fixed now....there was a problem with the linkage somehow....I removed the throttle body and something must have happened with that...all good now, it's now running at its normal 1750rpm...

    Can't wait to test it tomorrow on lake michigan....hopefully no more problems....knock on wood

    Thanks guys for all your help and thank you Jerry...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help installing XS intercooler in 05 RXP with stock exhaust
    By linuxglobal in forum 4-Tec Performance
    Replies: 13
    Last Post: 01-23-2011, 08:32 PM
  2. need help installing engine into rxp hull
    By bksbigboy69 in forum 4-Tec Performance
    Replies: 19
    Last Post: 11-03-2010, 08:35 PM
  3. Replies: 19
    Last Post: 06-28-2010, 08:11 PM
  4. WTB :=( need help installing riva rear intake
    By otoss in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 04-17-2010, 06:27 AM
  5. :=( need help installing riva rear intake
    By otoss in forum 4-Tec Performance
    Replies: 0
    Last Post: 04-17-2010, 06:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •