Results 1 to 6 of 6
  1. #1
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128

    P1602 & P1609 error codes?

    I finally got on the water (2005 RXP), still have some tuning to do, but at least the ski is water-worthy. The ski runs great altho I am over-propped at the moment. No problems, however I think my VTS motor bit the dust (display is fine, fuse was toast and it burnt another fuse and the VTS does not move). Just for the hell of it I checked for codes while out riding ... and came up with P1602 & P1609 ... and neither is listed in the standard error code listing. Anybody have any input on these codes? I pulled the battery over a long winter and switched to a Riva ECU setup ... just wondering what these codes are. They must be minor since the ski runs great, no beeps, no limp mode.


  2. #2
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    ttt Anybody?

  3. #3
    Website may not be suitable for small children WOT's Avatar
    Join Date
    Mar 2007
    Location
    DFW
    Posts
    654
    Are you sure it wasn't 1690 and 1692? Those are fault codes for VTS short and/or open circuit.

  4. #4
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128

    Talking My bad!

    Doh! I was going to ask an admin to delete this post ... you are so right, it WAS 1690 & 1692 ... and my VTS is displaying but not working ... fuse was burned out, so I put another one in, but no difference. I am guessing my VTS motor is toast and I will need another one ... second replacement if so ... seems like a yearly occurrence for me lately. Since we now have the right codes, do they usually indicate a bad VTS motor? They don't give those away but if I need one I want it NOW so I can put it in this weekend too ...

  5. #5
    Website may not be suitable for small children WOT's Avatar
    Join Date
    Mar 2007
    Location
    DFW
    Posts
    654
    It's prolly a bad motor, but the fault codes don't know if it shorted in the motor, or if the wiring has a short. Good luck!

  6. #6
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    I ordered a VTS motor, will test the old one first then install the new one this weekend ...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Who has gotten a P-0500 error code?
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 07-12-2012, 01:18 PM
  2. P-0500 error code??
    By BOOSTED in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-23-2010, 01:33 AM
  3. Id A - Error Code on Ultra
    By MrSxy4Ever in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 06-05-2007, 06:49 AM
  4. Sea-doo error code
    By stonylake rxp in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-18-2007, 10:27 PM
  5. Error code 1517 ????
    By ralphmalph3 in forum 4-Tec Performance
    Replies: 2
    Last Post: 03-10-2007, 11:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •